Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 234031 - Not possible to test multiple files or all files in package
Not possible to test multiple files or all files in package
Status: RESOLVED DUPLICATE of bug 124313
Product: java
Classification: Unclassified
Component: JUnit
7.4
PC Linux
: P2 (vote)
: TBD
Assigned To: Theofanis Oikonomou
junit-issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 15:26 UTC by Geertjan Wielenga
Modified: 2013-08-06 21:10 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Geertjan Wielenga 2013-08-06 15:26:06 UTC
It's possible to choose "Run File" on a project or on an individual Java source file, not on (1) a package and (2) on multiple selected files. Inconvenient for large projects.
Comment 1 Geertjan Wielenga 2013-08-06 15:55:29 UTC
Sorry, not "Run File", but "Test File".
Comment 2 dgilbert 2013-08-06 17:42:30 UTC
I asked Geertjan about this today and he opened this bug report for it.  While working on JFreeChart I often want to run all the tests for a single package in the project.  I was able to do this because I had defined some package test suites with JUnit 3.x.  But now I've updated to JUnit 4.11 and the test suites had to be removed.  Support for running tests on (a) a single package and (b) a multi-file selection would be useful to me, and I guess others.  Thanks.
Comment 3 markiewb 2013-08-06 21:10:41 UTC
Duplicate of #124313. Please vote there.

*** This bug has been marked as a duplicate of bug 124313 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo