Bug 232003 - syntax highlit and context hints not woring for Java
syntax highlit and context hints not woring for Java
Status: RESOLVED DUPLICATE of bug 227106
Product: java
Classification: Unclassified
Component: Editor
7.3.1
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Jan Lahoda
issues@java
: ERGONOMICS
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-28 16:04 UTC by alapierre
Modified: 2013-07-15 08:57 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (164.55 KB, text/plain)
2013-06-28 16:04 UTC, alapierre
Details
IDE screenshott (148.88 KB, image/png)
2013-06-28 16:07 UTC, alapierre
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alapierre 2013-06-28 16:04:02 UTC
Product Version = NetBeans IDE 7.3.1 (Build 201306052037)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_10
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.6-b04

syntax highlit and context hints not woring for Java. I had 7.3 installed before I installed 7.3.1 . I opened Java Maven project, previously created in 7.3 and after opening java source I see it as a normal text file.
Comment 1 alapierre 2013-06-28 16:04:11 UTC
Created attachment 136472 [details]
IDE log
Comment 2 alapierre 2013-06-28 16:07:24 UTC
Created attachment 136473 [details]
IDE screenshott

screenshot
Comment 3 Milos Kleint 2013-07-01 07:27:42 UTC
not maven project codebase related. the java file coloring for example is entirely independent.

The log file contains a few messages like this:
INFO [org.netbeans.modules.autoupdate.pluginimporter.ClusterUpdateProvider]: Jar file C:\Users\adrian.CS\AppData\Roaming\NetBeans\7.3\modules\org-netbeans-modules-java-sourceui.jar doesn't exists. Skip checking org.netbeans.modules.java.sourceui

Not sure how important it is, but I assume in general the problem lies in module system or upgrade codebase. reassigning
Comment 4 alapierre 2013-07-01 08:18:29 UTC
should I try reinstall NB 7.3.1? I can still working in 7.3, but maybe it will useful for you.
Comment 5 Jan Lahoda 2013-07-08 07:12:41 UTC
Reporter: I don't think there is a need to reinstall - restarting the IDE should be enough to workaround the problem.
Comment 6 alapierre 2013-07-08 07:20:03 UTC
Restart helped, but is there a chance for a thorough fix?
Comment 7 Jan Lahoda 2013-07-15 08:57:58 UTC
(In reply to comment #6)
> Restart helped, but is there a chance for a thorough fix?

Yes, there is a chance for a fix. Not sure what is the real cause yet, though.

*** This bug has been marked as a duplicate of bug 227106 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo