Bug 231515 - IDE freeze
IDE freeze
Status: RESOLVED DUPLICATE of bug 231013
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.4
PC Linux
: P3 (vote)
: TBD
Assigned To: Miloslav Metelka
issues@editor
: PERFORMANCE, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-19 11:45 UTC by Jesse Glick
Modified: 2013-06-20 16:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Sequence of thread dumps (5.03 KB, application/gzip)
2013-06-19 11:45 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2013-06-19 11:45:24 UTC
Created attachment 136023 [details]
Sequence of thread dumps

20130617-56bd2b207b91. Had been editing various Java sources, etc. Now tried to select a bit of text from a hyperlink in changelog.html in Jenkins sources. The IDE suddenly got very slow. I gave up, closed this window, and tried to click in another source window; now the IDE froze completely, initially with ~300% CPU, then 100% CPU. Got some thread dumps before I killed it.
Comment 1 Miloslav Metelka 2013-06-20 16:27:49 UTC
Hi Jesse,
it should be dup of issue 231013 (though in that one's threaddump there's a thread doing closeDocument() as well but that should not matter). I'm working on a fix.

*** This bug has been marked as a duplicate of bug 231013 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo