Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 231148 - @Override shoul be added when extract abstract superclass
@Override shoul be added when extract abstract superclass
Status: RESOLVED DUPLICATE of bug 205064
Product: java
Classification: Unclassified
Component: Refactoring
7.3.1
PC Windows 7
: P4 (vote)
: TBD
Assigned To: Ralph Ruijs
issues@java
:
: 254950 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 13:27 UTC by ssazonov
Modified: 2015-09-11 08:31 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ssazonov 2013-06-12 13:27:47 UTC
1. Create class 'SimpleClass' and insert this code:

  //---------------------------
  public class SimpleClass {
    
      public void simpleMethod() { }
    
  }
  //---------------------------

2. Select 'SimpleClass'

3. Go to Refactor->Extract Superclass...

4. Set Superclass Name: 'AnotherClass', check method 'simpleMethod()' and check Make abstract, than press Refactor

>> Method simpleMethod() shoul have @Override annotation

Product Version: NetBeans IDE 7.3.1 (Build 201306052037)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b30
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 1 Jiri Prox 2015-09-03 10:12:30 UTC
*** Bug 254950 has been marked as a duplicate of this bug. ***
Comment 2 MackSix 2015-09-11 08:27:32 UTC

*** This bug has been marked as a duplicate of bug 205064 ***
Comment 3 MackSix 2015-09-11 08:31:35 UTC
This is actually a duplicate of an Enhancement. If it is not proper to mark a bug a duplicate of an Enhancement, please change back.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo