Bug 231126 - ArrayIndexOutOfBoundsException at java.lang.System.arraycopy
ArrayIndexOutOfBoundsException at java.lang.System.arraycopy
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Plugin Manager
7.3
All All
: P4 (vote)
: TBD
Assigned To: Libor Fischmeistr
au-issues
EXCEPTIONS_REPORT
: JDK_8
Depends on: 231128
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 11:19 UTC by hantsy
Modified: 2015-02-04 03:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.09 KB, text/plain)
2013-06-12 11:19 UTC, hantsy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hantsy 2013-06-12 11:19:50 UTC
Build: NetBeans IDE 7.3.1 (Build 201306052037)
VM: Java HotSpot(TM) 64-Bit Server VM, 25.0-b34, Java(TM) SE Runtime Environment, 1.8.0-ea-b93
OS: Windows 7

User Comments:
hantsy: 1. upgrade to netbeans 7.3.1.
2. import plugins from nb7.3




Stacktrace: 
java.lang.ArrayIndexOutOfBoundsException
   at java.lang.System.arraycopy(System.java:0)
   at javax.swing.text.CompositeView.replace(CompositeView.java:204)
   at javax.swing.text.View.updateChildren(View.java:1116)
   at javax.swing.text.View.changedUpdate(View.java:782)
   at javax.swing.text.FlowView.changedUpdate(FlowView.java:283)
   at javax.swing.text.ParagraphView.changedUpdate(ParagraphView.java:795)
Comment 1 hantsy 2013-06-12 11:19:52 UTC
Created attachment 135675 [details]
stacktrace
Comment 2 Marian Mirilovic 2013-06-26 14:46:31 UTC
So far all reports on JDK 8 ... does it mean it's reproducible only with JDK8 ?
Comment 3 Jiri Rechtacek 2013-06-28 12:30:57 UTC
Same as issue 231128. I'm afraid we are not able to fix that bug, should be filed in JDK bugs rather.
Comment 4 Quality Engineering 2015-02-04 03:32:36 UTC
Reported for 7.3.x or earlier, no new info since then -> closing as worksforme, please reopen in case you see it.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo