Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 229988 - Select Deployment server: Remember Permanently may not work
Select Deployment server: Remember Permanently may not work
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Maven
7.3.1
PC Windows 7
: P2 (vote)
: 7.3.1
Assigned To: Martin Janicek
issues@javaee
731_HR_FIX
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 10:54 UTC by MackSix
Modified: 2013-05-23 07:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (937 bytes, patch)
2013-05-22 12:04 UTC, Martin Janicek
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description MackSix 2013-05-20 10:54:26 UTC
I created the Java EE 7 Threads Concurrency Sample (Sample Application using ManagedThreadFactory) and when I run it, it prompts me to "Select Deployment server" and I select "Remember Permanently" and GlassFish Server 4.0, but when it runs, the output says: "NetBeans: No suitable Deployment Server is defined for the project or globally."

I tried to create 2 of the other sample Java EE 7 projects and ran across the same issue.

If I choose "Remember in current IDE session" then it works.


Product Version: NetBeans IDE 7.3.1 RC (Build 201305162200)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 1 Petr Jiricka 2013-05-20 13:20:41 UTC
This sounds serious -> P2.
Comment 2 Petr Jiricka 2013-05-21 12:13:52 UTC
Reproducible.
Comment 3 Martin Janicek 2013-05-22 12:04:47 UTC
Created attachment 134737 [details]
Proposed patch

This works for me in trunk, doesn't work on release73 repository --> I'm attaching the patch fixing the problem also in release73 repo (same code is already in trunk). 

Not sure what is the process in such case, should I close the issue as FIXED, set TM = 7.4, mark it as 731_HR_FIX_CANDIDATE and then ask someone for "patch verification" ??
Comment 4 Martin Janicek 2013-05-22 12:38:59 UTC
Fixed in: releases #24197b990f5b

Setting TM = 7.3.1, adding 731_HR_FIX, closing as FIXED
Comment 5 Quality Engineering 2013-05-23 00:18:45 UTC
Integrated into 'releases', will be available in build *201305222200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/24197b990f5b
User: Martin Janicek <mjanicek@netbeans.org>
Log: #229988 - Select Deployment server: Remember Permanently may not work


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo