Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 229944 - [73cat] GlassFish install recognition problem
[73cat] GlassFish install recognition problem
Status: RESOLVED FIXED
Product: installer
Classification: Unclassified
Component: Code
7.3.1
PC Windows 8 x64
: P2 (vote)
: 7.4
Assigned To: Jiri Rechtacek
issues@installer
:
: 229987 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 14:29 UTC by muellermi
Modified: 2013-07-09 04:23 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description muellermi 2013-05-18 14:29:41 UTC
- Start installer on a PC with previously NB isnatalaltion (including GF4)

Checkbox "GlassFish Server ... 4.0" is checked and enabled
--> must be checked and disabled, with additional hint "already installed"

next, ..., next
Install GlassFish to C:\Program Files\glassfish-4.0
folder is not empty
right. 
NB installer finds the old installation. Of course, it is already installed.
Comment 1 Petr Jiricka 2013-05-20 07:51:22 UTC
Michael, if this is a 7.3.1 stopper as you mentioned on the NetCAT mailing list, then it should be a P2 at least.

I did not try this, but are you saying that the installer does not allow you to proceed if GF 4 installation already exists? Thanks.
Comment 2 Jiri Rechtacek 2013-05-20 13:55:37 UTC
(In reply to comment #1)
> Michael, if this is a 7.3.1 stopper as you mentioned on the NetCAT mailing
> list, then it should be a P2 at least.
> 
> I did not try this, but are you saying that the installer does not allow you to
> proceed if GF 4 installation already exists? Thanks.

It's not a showstopper. Michael has already installed a different development build of GF4 then the build which is bundled in 7.3.1 RC1 IDE. So, the scenario is correct from technical point of view. It's consistent with other product/part of IDE. Michael, what are suggesting from user point of view?
Comment 3 Jiri Rechtacek 2013-05-20 18:50:07 UTC
*** Bug 229987 has been marked as a duplicate of this bug. ***
Comment 4 Jiri Rechtacek 2013-05-20 19:39:44 UTC
Michael Müller:
> No, the scenario is not ok.
> 
> The installer has to detect an existing installation and to report 
> "GlassFish... already installed".
I think the installer does it. Following the steps: install 7.3.1 RC1 + GF4, uninstall 7.3.1 RC1 but leave the GF4 installed and then install 7.3.1 RC1 again. The installer marks it as Already installed. It is true?

> The current version does not detect an existing GF. This is not a 
Well. But what is "the existing GF"? I guess it's an older development build of GF4, probably older one than the GF4 which is bundled with 7.3.1 (i.e. b89). In that case the installer cannot skip it and keep the older one for using with IDE. It may cause unexpected behavior of GF later. The installer has to enforce install the latest build of GF4.

> showstopper. But IMHO it should work as good as it did before.
It's a different case. The previous releases didn't bundle a development version of GF but with the final bits. This confusing is caused by bundling of non-final bits during development of NetBeans 7.3.1. However the final build of 7.3.1 will contain final build of GF4 as well, only NetCat participants may face to this confusing of non-final bits of GF4.

An possible solution: the installer could warn the users when detect previous (non-final) build of GF4 and prevent users to install newer GF4 if an previous build still installed. Does it make any sense?
Comment 5 Jiri Rechtacek 2013-05-21 16:12:42 UTC
It was agreed it's not a showstopper for 7.3.1 - the proposed improvement of notification for users will be solved for the next release.
Comment 6 Jiri Rechtacek 2013-07-07 21:00:52 UTC
http://hg.netbeans.org/core-main/rev/de1508a2cb7f
Comment 7 Quality Engineering 2013-07-09 04:23:41 UTC
Integrated into 'main-silver', will be available in build *201307082300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/de1508a2cb7f
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #229944 - [73cat] GlassFish install recognition problem


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo