Bug 229794 - User can't create valid project via "C/C++ Project with Existing Sources" wizard if she/he uses java 7 update 21
User can't create valid project via "C/C++ Project with Existing Sources" wiz...
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
7.3.1
PC Windows XP
: P3 (vote)
: 7.4
Assigned To: Alexander Simon
issues@cnd
:
: 235375 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 14:20 UTC by soldatov
Modified: 2013-09-02 07:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2013-05-15 14:20:29 UTC
Window XP, MinGW and java 7 update 21

In NetBeans 7.3 patch 2 or trunk I can't create new project via "C/C++ Project with Existing Sources" wizard (small Qt sample - calculator)

Workaround:
 replace C:/MinGW/msys/1.0/bin/make.exe on make.exe in Tools|Options
 remove cygwin (if cygwin exist, then NetBeans will use cygwin's make in any
case)
Comment 1 soldatov 2013-05-15 14:30:24 UTC
Scenario:
- Unpack project
- Call "C/C++ Project with Existing Sources" wizard
- Select Automatic mode
==> Project has broken code assistance, Output tab displays errors

"Makefile (Make) clean" tab:
--------------------------------------------------------------------
/c/test_projects/calculator/"C:/MinGW/msys/1.0/bin/make.exe" -f Makefile.Debug clean
/bin/sh: /c/test_projects/calculator/C:/MinGW/msys/1.0/bin/make.exe: No such file or directory
make.exe": *** [debug-clean] Error 127


MAKE FAILED (exit value 2, total time: 2s)
--------------------------------------------------------------------

"Makefile (Make)" tab:
--------------------------------------------------------------------
/c/test_projects/calculator/"C:/MinGW/msys/1.0/bin/make.exe" -f Makefile.Debug
/bin/sh: /c/test_projects/calculator/C:/MinGW/msys/1.0/bin/make.exe: No such file or directory
make.exe": *** [debug] Error 127


MAKE FAILED (exit value 2, total time: 1s)
--------------------------------------------------------------------
Comment 2 Egor Ushakov 2013-05-23 14:57:52 UTC
isn't this a duplicate of bug 228730?
Comment 3 soldatov 2013-05-23 16:01:10 UTC
(In reply to comment #2)
> isn't this a duplicate of bug 228730?
No. We fix most common scenario only.
Comment 4 Alexander Simon 2013-08-20 16:02:11 UTC
fixed, change set:
http://hg.netbeans.org/cnd-main/rev/24e2a18de691
Comment 5 Alexander Simon 2013-09-02 07:22:26 UTC
*** Bug 235375 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo