Bug 229774 - Export/import of options settings misbehaviour in 7.3 + patch2
Export/import of options settings misbehaviour in 7.3 + patch2
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Options&Settings
7.3
PC Mac OS X
: P3 (vote)
: 7.3.1
Assigned To: Theofanis Oikonomou
issues@platform
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 11:43 UTC by Tomas Danek
Modified: 2013-05-17 07:41 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
logfile (38.13 KB, application/octet-stream)
2013-05-15 15:15 UTC, Tomas Danek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2013-05-15 11:43:59 UTC
Product Version: NetBeans IDE 7.3 (Build 201305142200)
Java: 1.7.0_21; Java HotSpot(TM) 64-Bit Server VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b12
System: Mac OS X version 10.8.3 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.3
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.3
-------------------------
- update 7.3 to patch2 using latest 7.3.1 catalog.xml (2013-05-14_22-00-56)
- open Preferences
- change something in Java | Maven category, save
- open Preferences
- export
- change back to default, save
- open Preferences
- import

=> no question about restart is asked, options dialog blinks; if you close Options  dialog, and reopen it again, imported preferences are present, so actual import was preformed, but without restart of IDE, which is not desired behaviour (see issue 226998 , comment 7).

If this scenario is performed on 7.3.1 build 2013-05-14_22-00-56 (i.e. the same as 7.3 is updated to from catalog.xml), it works as expected. Probably some misconfiguration in module dependencies?!
Comment 1 Tomas Danek 2013-05-15 14:39:20 UTC
it seems like even upgrade scenario makes the difference; now i tested:
7.3 C/C++ installation ->  extended to all -> updated to patch2 

and it's not reproducible.
Comment 2 Tomas Danek 2013-05-15 15:08:27 UTC
and in scenario

install 7.3 all -> activate javase -> update to patch1 -> update to patch2

it is reproducible.  Attaching log file, to see what modules are the versions of modules.
Comment 3 Tomas Danek 2013-05-15 15:15:38 UTC
Created attachment 134479 [details]
logfile
Comment 4 Tomas Danek 2013-05-16 10:06:16 UTC
We found that problem is netbeans/nb/modules/locale/org-netbeans-modules-options-api_nb.jar module, which in contains Bundle.properties with key: OPT_RestartAfterImport=true . However, because branding is excluded from update, this does not get into 7.3 patch2.

I've verified, that if we move the entry OPT_RestartAfterImport=true into netbeans/platform/modules/org-netbeans-modules-options-api.jar , it solves this problem.
Comment 5 Theofanis Oikonomou 2013-05-16 11:53:46 UTC
Fixed ONLY in release73 branch: http://hg.netbeans.org/releases/rev/52b52911dab8

The default behavior in 7.3.1 will be to require restart after importing options. For platform applications that do not require restart this will have to be branded on their side.

From 7.4 onwards the default behavior will be NOT to require restart after importing options so platform applications that do not require restart after importing options will work out of the box.
Comment 6 Tomas Danek 2013-05-17 07:41:24 UTC
verified in patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo