Bug 228685 - Inaccurate parameter's name in help window
Inaccurate parameter's name in help window
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
7.4
All All
: P3 (vote)
: 7.3.1
Assigned To: Martin Fousek
issues@javaee
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-18 09:09 UTC by Vladimir Riha
Modified: 2013-05-09 14:04 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2013-04-18 09:09:05 UTC
In jsp file, try:

<% request.getSession().p|

and invoke cc

=> help shows (String arg0, Object arg1), in 7.3, there used to be (String name, Object value) (in 7.4, this is actually in parameter's description text)



Product Version: NetBeans IDE Dev (Build 201304172301)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.2.0-40-generic-pae running on i386; UTF-8; en_US (nb)
Comment 1 Vladimir Riha 2013-04-18 09:14:55 UTC
Possible (nice to have) patch candidate, but not necessary
Comment 2 Martin Fousek 2013-04-23 08:17:20 UTC
It's caused by NPE from TreeLoader. I have a patch for fixing this issue but I would like to discus it with the code owner first. Anyway targeting issue to the NB7.3.1.
Comment 3 Martin Fousek 2013-04-23 11:59:17 UTC
Fixed by web-main #d7f797e74510.
Comment 4 Vladimir Riha 2013-04-30 10:52:17 UTC
Thank you, verified


Product Version: NetBeans IDE Dev (Build web-main-10412-on-20130430)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.2.0-40-generic-pae running on i386; UTF-8; en_US (nb)
Comment 5 Vladimir Riha 2013-05-09 14:04:36 UTC
patch2 verified

Product Version: NetBeans IDE 7.3.1 (Build 201302132200)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.2.0-41-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo