Bug 228214 - AssertionError at org.netbeans.modules.web.core.jsploader.TagLibParseSupport$ParsingRunnable.run
AssertionError at org.netbeans.modules.web.core.jsploader.TagLibParseSupport$...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: JSP
7.4
All All
: P3 (vote)
: 7.3.1
Assigned To: Petr Hejl
issues@javaee
auttests, 73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-03 15:39 UTC by Vladimir Riha
Modified: 2013-05-09 14:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (71.63 KB, text/x-log)
2013-04-03 15:39 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2013-04-03 15:39:15 UTC
Created attachment 133283 [details]
IDE log

This AE is popping out in automated tests, I cannot reproduce it manually but thanks to this, (at least I think - it is the only difference), the test fails.

To reproduce run test

org.netbeans.test.syntax.AutoCompletionTest

located in web.core.syntax module under functional tests



  Product Version         = NetBeans IDE Dev (Build 20130402-0255877c1755) (#0255877c1755)
  Operating System        = Linux version 3.2.0-39-generic-pae running on i386
  Java; VM; Vendor        = 1.7.0_17; Java HotSpot(TM) Server VM 23.7-b01; Oracle Corporation
  Runtime                 = Java(TM) SE Runtime Environment 1.7.0_17-b32
  Java Home               = /home/vriha/jdk1.7.0_17/jre
Comment 1 Vladimir Riha 2013-04-03 15:51:50 UTC
It seems to be randomly reproducible if you simply open the project [1] in IDE, 


[1] web.core.syntax/test/qa-functional/data/AutoCompletionTestProjects/AutoCompletionProject
Comment 2 Martin Fousek 2013-04-03 16:47:19 UTC
I'll take a look.
Comment 3 Vladimir Riha 2013-04-03 17:02:12 UTC
Thanks in advance :)
Comment 4 Petr Hejl 2013-04-05 12:58:01 UTC
Fixed in web-main 296bec5f18fc. Though there might be another issue #228283.
Comment 5 Petr Hejl 2013-04-05 13:51:39 UTC
Transplanted also to javaee7 78052b4f755b.
Comment 6 Vladimir Riha 2013-04-08 10:55:35 UTC
Seems ok, thanks again

Product Version: NetBeans IDE Dev (Build web-main-10256-on-20130406)
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b32
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 7 Marian Mirilovic 2013-05-03 09:17:42 UTC
So, where exactly is this issue fixed ? Is it already in release73 repository ? If so, please change SW to '73patch2-fixed', thanks in advance.
Comment 8 Vladimir Riha 2013-05-09 14:22:49 UTC
patch2 verified

Product Version: NetBeans IDE 7.3.1 (Build 201302132200)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.2.0-41-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo