Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 228196 - Icorrect encoding when editing .properties file
Icorrect encoding when editing .properties file
Status: RESOLVED DUPLICATE of bug 75906
Product: utilities
Classification: Unclassified
Component: Properties
7.4
PC Windows 7
: P2 (vote)
: TBD
Assigned To: Jan Peska
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-03 11:38 UTC by ecerichter
Modified: 2013-04-03 11:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of Notepad++ (48.23 KB, image/png)
2013-04-03 11:38 UTC, ecerichter
Details
Screenshot of NetBeans (113.57 KB, image/png)
2013-04-03 11:39 UTC, ecerichter
Details
Sample file for testing (218 bytes, text/x-properties)
2013-04-03 11:40 UTC, ecerichter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ecerichter 2013-04-03 11:38:04 UTC
Product Version = NetBeans IDE Dev (Build 201304012300)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_17
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01

We have a .properties file that is encoded as UTF-8 without BOM.
I can edit this file in Eclipse and also in Notepad++, but when I open the file in NetBeans, the encoding is wrong.

Attached there is the screenshot of the file in NetBeans with project properties, showing that the project is correctly set to UTF-8.
Also, there is the screenshot of Notepad++ showing the current encoding of the file (Notepad++ has a nice feature of auto-detect encodings that is awesome).

I've added the first portion of the file that includes native characters (brazilian). I hope this helps.

Regards,

Edson
Comment 1 ecerichter 2013-04-03 11:38:54 UTC
Created attachment 133275 [details]
Screenshot of Notepad++
Comment 2 ecerichter 2013-04-03 11:39:36 UTC
Created attachment 133276 [details]
Screenshot of NetBeans
Comment 3 ecerichter 2013-04-03 11:40:15 UTC
Created attachment 133277 [details]
Sample file for testing
Comment 4 Jan Peska 2013-04-03 11:58:23 UTC

*** This bug has been marked as a duplicate of bug 75906 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo