Bug 228066 - IllegalArgumentException: Copying to 3660 is greater then its size (3657).
IllegalArgumentException: Copying to 3660 is greater then its size (3657).
Status: RESOLVED INCOMPLETE
Product: java
Classification: Unclassified
Component: Source
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Svata Dedic
issues@java
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-28 21:24 UTC by alied
Modified: 2013-07-26 10:44 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.87 KB, text/plain)
2013-03-28 21:24 UTC, alied
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alied 2013-03-28 21:24:20 UTC
Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_15-b03
OS: Windows 7

User Comments:
alied: dragging an drop from a method to another.




Stacktrace: 
java.lang.IllegalArgumentException: Copying to 3660 is greater then its size (3657).
   at org.netbeans.modules.java.source.save.CasualDiff.copyTo(CasualDiff.java:3761)
   at org.netbeans.modules.java.source.save.CasualDiff.copyTo(CasualDiff.java:3740)
   at org.netbeans.modules.java.source.save.CasualDiff.diffCommentLists(CasualDiff.java:3073)
   at org.netbeans.modules.java.source.save.CasualDiff.diffPrecedingComments(CasualDiff.java:2992)
   at org.netbeans.modules.java.source.save.CasualDiff.diffPrecedingComments(CasualDiff.java:2982)
   at org.netbeans.modules.java.source.save.CasualDiff.diffTreeImpl(CasualDiff.java:3234)
Comment 1 alied 2013-03-28 21:24:22 UTC
Created attachment 133190 [details]
stacktrace
Comment 2 Svata Dedic 2013-07-26 10:44:34 UTC
Cannot reproduce on 7.3 release or dev version - please attach your java formatting settings (export your options - Tools | Options -> Export, be sure to check All or Formatting)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo