Bug 228032 - Project is corrupted
Project is corrupted
Status: RESOLVED INCOMPLETE
Product: php
Classification: Unclassified
Component: Project
7.3
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: Tomas Mysik
issues@php
: I18N, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-28 10:23 UTC by legitalk
Modified: 2013-04-08 10:38 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (60.58 KB, text/plain)
2013-03-28 10:23 UTC, legitalk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description legitalk 2013-03-28 10:23:32 UTC
This started happening since 7.3.

It is happening randomly, and it changed project encoding from UTF8 => CP1250. Then my file encoding went wrong. I wanted to go to project properties, but I cant. I throw an error "Project ... is corrupted". Then all opened files lost their names (I ment the open files names in tabs), there is everywhere empty filename and X to close that tab.

It cant be fixed, because when I click "Resolve" in "Project ... is corrupted" dialog, there is no error to resolve. I have to close whole NetBeans, and reopen all tabs. BUT! Encoding of all files is changed and this is pretty bad :( everything is save with different encoding and cant be undone. When I change then project encoding, the files stayed already with wrong encoding letters :( Only backup of that files is the sollution.




Product Version = NetBeans IDE 7.3 (Build 201302132200)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.6.0_24
Runtime = Java HotSpot(TM) Client VM 19.1-b02
Comment 1 legitalk 2013-03-28 10:23:37 UTC
Created attachment 133165 [details]
IDE log
Comment 2 Milos Kleint 2013-04-02 08:44:34 UTC
what project type are your affected projects?
Comment 3 Milos Kleint 2013-04-02 11:08:12 UTC
based on list of clusters in the log file, it should be php projects. Reassigning to php
Comment 4 Tomas Mysik 2013-04-02 14:32:20 UTC
"Project ... is corrupted" means that your project does not have Source Files so it cannot be customized; where do you have your Source Files - on local or remote (network) drive? Do you have exact steps to reproduce this problem, please?

In the log, I can see only one suspicious thing [1].

Simply reopen this issue, thanks.

[1]
INFO [org.netbeans.modules.masterfs.watcher.windows.WindowsNotifier]: handleChanges
java.io.IOException: ReadDirectoryChangesW failed on G:\: 64
Comment 5 legitalk 2013-04-02 17:53:23 UTC
Yes, its PHP.. and its on local network, which is still accessible..
Comment 6 Tomas Mysik 2013-04-03 07:23:29 UTC
@reporter: It seems to me that your network drive is disconnected (maybe just for a while) and NetBeans detects it so the project sources are lost. Do you use also any other project types other than PHP? If not, could you please create e.g. Java Web project and try to reproduce the problem with it? I mean simply to have a Java Web project opened in NetBeans (with some opened HTML file(s) from it) and if the problem occurs, just check whether the encoding problem happens also to this Java Web project file. If yes, the problem will be general; if not the problem will be in PHP area.

@kanakmar: Martine, please, try to reproduce the issue (have sources on a network drive and try to disconnect it).

Thanks a lot for your cooperation.
Comment 7 legitalk 2013-04-04 07:52:14 UTC
I tried to manualy disconnect network connection, Netbeans showed messages, that files are no longer accessible, and normaly closed them. So this is not the problem. When it happend, network connection was enabled and message "project is corrupt" appeared.
Comment 8 Tomas Mysik 2013-04-04 08:59:27 UTC
(In reply to comment #7)
> I tried to manualy disconnect network connection, Netbeans showed messages,
> that files are no longer accessible, and normaly closed them. So this is not
> the problem. When it happend, network connection was enabled and message
> "project is corrupt" appeared.

In such case, I am afraid that we really need a reproducible case otherwise we are not able to help you, sorry. It would be great if you could find out the cause of this problem.

Thanks a lot.
Comment 9 Martin Kanak 2013-04-04 09:13:30 UTC
(In reply to comment #6)
> @kanakmar: Martine, please, try to reproduce the issue (have sources on a
> network drive and try to disconnect it).

I try to reproduce this issue, but I am not able to reproduce that. What I have done:
- open project, which is located on network drive => everything works fine
- then I disconnect the network drive => project files in the editor shut down, in project properties there is a warning "Source directory does not exist"
- then I connect the network drive => everything works fine again, no changes in project properties (encoding incl.)
Comment 10 legitalk 2013-04-08 10:23:40 UTC
(In reply to comment #9)
> (In reply to comment #6)
> > @kanakmar: Martine, please, try to reproduce the issue (have sources on a
> > network drive and try to disconnect it).
> 
> I try to reproduce this issue, but I am not able to reproduce that. What I have
> done:
> - open project, which is located on network drive => everything works fine
> - then I disconnect the network drive => project files in the editor shut down,
> in project properties there is a warning "Source directory does not exist"
> - then I connect the network drive => everything works fine again, no changes
> in project properties (encoding incl.)

So, I tried it again, the same steps as you did. But I reconnect network drive right after I disconnect it. All opened files were slowly closing. Then I reopen one file, but his project were still not loaded. And then it happens:
- message that file is in different encoding, and after opening it, there were problems with encoding, as it says.
- then I tried to go to project properties, and that errors occured - project is corrupted.

I think, is something with that, when network connection is lost, and then restored, files are accessible in a moment, but projects data are not loaded (but should be also accessible).

Let me know, if I can help somehow more.
Comment 11 Tomas Mysik 2013-04-08 10:38:26 UTC
@reporter: Could you please try it also with a Java Web project? I wrote exact steps in the comment #6.
(I am just trying to find out whether the encoding problem is general or PHP specific.)

Thanks a lot.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo