Bug 228008 - NullPointerException at org.netbeans.modules.web.el.hints.Identifiers.isValidNode
NullPointerException at org.netbeans.modules.web.el.hints.Identifiers.isValid...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Expression Language
7.3.1
All All
: P2 (vote)
: 7.3.1
Assigned To: Martin Fousek
issues@javaee
EXCEPTIONS_REPORT, 73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-27 15:09 UTC by Vladimir Riha
Modified: 2013-05-09 14:25 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.92 KB, text/plain)
2013-03-27 15:09 UTC, Vladimir Riha
Details
sample file (1.10 KB, application/octet-stream)
2013-03-27 15:14 UTC, Vladimir Riha
Details
log from build #195 (3.92 KB, text/x-log)
2013-03-29 15:07 UTC, Vladimir Riha
Details
sample project (2.75 MB, application/zip)
2013-04-03 15:57 UTC, Vladimir Riha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2013-03-27 15:09:57 UTC
Build: NetBeans IDE Dev (Build web-main-javaee7-189-on-20130327)
VM: Java HotSpot(TM) Client VM, 23.7-b01, Java(TM) SE Runtime Environment, 1.7.0_17-b32
OS: Linux

User Comments:
vriha: Typing in JSP page with EL 3 inside, last EL I wrote was

 ${car["repaint"]("pink")}




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.web.el.hints.Identifiers.isValidNode(Identifiers.java:142)
   at org.netbeans.modules.web.el.hints.Identifiers.access$000(Identifiers.java:64)
   at org.netbeans.modules.web.el.hints.Identifiers$1.visit(Identifiers.java:118)
   at com.sun.el.parser.SimpleNode.accept(SimpleNode.java:222)
   at com.sun.el.parser.SimpleNode.accept(SimpleNode.java:225)
   at com.sun.el.parser.SimpleNode.accept(SimpleNode.java:225)
Comment 1 Vladimir Riha 2013-03-27 15:09:59 UTC
Created attachment 133139 [details]
stacktrace
Comment 2 Vladimir Riha 2013-03-27 15:11:33 UTC
Maybe belongs here? Please reassign if not.
Comment 3 Vladimir Riha 2013-03-27 15:14:25 UTC
Created attachment 133140 [details]
sample file

If I open this file in editor and start "clicking" near

${car["repaint"]("pink")}

the NPE pops out
Comment 4 Vladimir Riha 2013-03-27 15:18:43 UTC
happens on file opening and then basically on each keystroke that produces some text in editor => P2
Comment 5 Milutin Kristofic 2013-03-27 15:27:01 UTC
web.el -> javaee Expression Language
Comment 6 Vladimir Riha 2013-03-27 15:39:36 UTC
This must be fixed for 7.3.1, it is caused by sequence of [] and ()

${car["repaint"]("pink")}

removing it helps
Comment 7 Martin Fousek 2013-03-29 10:24:09 UTC
It gets rewrite which is available in build #191+ and I'm not able to reproduce it there, please give another try in the newest build and feel free to reopen it if this issue appears. Thanks a lot.

For now looks to me fixed in web-main #745fb832ac6f.
Comment 8 Vladimir Riha 2013-03-29 15:07:35 UTC
I'm sorry, still reproducible



Product Version: NetBeans IDE Dev (Build web-main-javaee7-195-on-20130328)
Updates: Updates available
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b32
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 9 Vladimir Riha 2013-03-29 15:07:55 UTC
Created attachment 133214 [details]
log from build #195
Comment 10 Martin Fousek 2013-03-29 17:24:57 UTC
OK, thanks for your attempt. Could you attach your whole sample project please? Thanks...
Comment 11 Vladimir Riha 2013-04-03 15:57:57 UTC
Created attachment 133284 [details]
sample project

I'm sorry for delay. Simply open ok.jsp and start typing
Comment 12 Martin Fousek 2013-04-04 06:37:49 UTC
Thanks for the project. The issue was finally pretty clear, I don't know why I thought that no-image nodes have image empty and not null. Should be fixed in web-main #278090eade38.

Anyway it brings another issue that expression is underlined with strange message since the method call over [''] is not supported by our EL yet. Please feel free report it into the new issue.

Thanks a lot!
Comment 13 Vladimir Riha 2013-04-04 11:07:41 UTC
Thanks, now it is fine.

The [] issue is filed as issue 228243.


Product Version: NetBeans IDE Dev (Build web-main-javaee7-203-on-20130404)
Java: 1.7.0_17; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_17-b32
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 14 Marian Mirilovic 2013-05-03 09:13:16 UTC
I expect, this is already in release73 -> '73patch2-fixed'
Comment 15 Vladimir Riha 2013-05-09 14:25:22 UTC
patch2 verified

Product Version: NetBeans IDE 7.3.1 (Build 201302132200)
Java: 1.7.0_21; Java HotSpot(TM) Client VM 23.21-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_21-b11
System: Linux version 3.2.0-41-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo