Bug 227646 - Some breakpoints are not marked in editor left bar
Some breakpoints are not marked in editor left bar
Status: RESOLVED DUPLICATE of bug 226219
Product: debugger
Classification: Unclassified
Component: Java
7.4
All All
: P2 (vote)
: TBD
Assigned To: Martin Entlicher
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-19 01:59 UTC by ecerichter
Modified: 2013-04-26 09:45 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (18.09 KB, text/plain)
2013-03-19 01:59 UTC, ecerichter
Details
Screenshot of editor without the breakpoint mark (see the breakpoint below in the image) (20.82 KB, image/png)
2013-03-19 02:00 UTC, ecerichter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ecerichter 2013-03-19 01:59:08 UTC
Product Version = NetBeans IDE Dev (Build 201303142300)
Operating System = Windows 7 version 6.1 running on amd64
Java; VM; Vendor = 1.7.0_17
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.7-b01

This is not frequent, but happens from time-to-time that breakpoints are shown in Breakpoints window, but are not visible in editor bar.
The breakpoint exists and is active (the prove is that debugger stops in the correct line), but is not visible in editor.
Comment 1 ecerichter 2013-03-19 01:59:16 UTC
Created attachment 132775 [details]
IDE log
Comment 2 ecerichter 2013-03-19 02:00:19 UTC
Created attachment 132776 [details]
Screenshot of editor without the breakpoint mark (see the breakpoint below in the image)
Comment 3 Dusan Balek 2013-03-22 15:03:22 UTC
Reassigning to debugger for evaluation.
Comment 4 Martin Entlicher 2013-03-22 15:14:10 UTC
Can you please attach the whole messages.log file?
This is just a small snippet. It is possible, that some exception occurs, which breaks the breakpoints highlighting.
I'll check if message "Disabled an invalid highlighting layer..." can have any relation to this problem.
Any steps that could be used to reproduce this problem are welcomed.
Comment 5 ecerichter 2013-03-22 15:22:45 UTC
I suppose this is the whole log.
I've used the "attach log" option inside the Team -> Report issue.

I'll check if there is other, more complete, log available, but I'm afraid not.
Comment 6 Martin Entlicher 2013-03-22 15:31:33 UTC
The full log file (called messages.log) should be in
<NetBeans user directory>/var/log/ folder. But if you've run NetBeans since then, it's either renamed as messages.log.1 or messages.log.2 or it's gone.
It would be best if you could recall how to reproduce this. Thanks.
Comment 7 ecerichter 2013-03-22 15:48:30 UTC
I don't have it anymore.
It is strange it not uploaded entirely.
I'll try to reproduce. As said in OP, it doesn't happen always, but normally in long debug sessions.
Comment 8 bht 2013-04-26 09:45:09 UTC
Bug 226219 has quite a few logs already, so please attach logs there if you observe this again. Thanks.

*** This bug has been marked as a duplicate of bug 226219 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo