Bug 227494 - Alt+Shift+O Goto File fails to go to the selected file.
Alt+Shift+O Goto File fails to go to the selected file.
Status: RESOLVED FIXED
Product: utilities
Classification: Unclassified
Component: Jump To
7.3
PC Windows 7
: P3 with 1 vote (vote)
: 7.4
Assigned To: Tomas Zezula
issues@utilities
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-14 18:42 UTC by swpalmer
Modified: 2013-06-07 07:55 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (98.05 KB, text/plain)
2013-03-14 18:42 UTC, swpalmer
Details
does-not-work-with-this-projekt.tar.gz (13.02 KB, application/x-gzip)
2013-04-22 10:17 UTC, JensHillert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swpalmer 2013-03-14 18:42:05 UTC
Product Version = NetBeans IDE 7.3 (Build 201302132200)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.7.0_15
Runtime = Java HotSpot(TM) Client VM 23.7-b01

This usually works, but today nothing happens after selecting the file in my Maven project.  The file shows twice in the list.  Once with "src/main/java/" prepended to the package part of the path and once without.  Neither item in the list works.
Comment 1 swpalmer 2013-03-14 18:42:09 UTC
Created attachment 132623 [details]
IDE log
Comment 2 Tomas Zezula 2013-03-19 17:31:51 UTC
Seems as a wrong classpath root.
Can you attach the project or reproduceable test case?
Comment 3 swpalmer 2013-03-19 19:48:55 UTC
Funny you should be doing this now.. I just discovered a few hours ago that my project folder had a strange structure caused by an extra nested working copy. It is still a bit strange since that folder was not a child of the project that was having issues, but it was still within Maven's view from the parent project.
I think it is safe to leave this closed.
Comment 4 swpalmer 2013-03-28 13:42:41 UTC
Just had this happen again.  This time I know the classpath to be correct.

The file in question is a form.  I do Alt-Shit-O and type the start of the name and get offered only two options, the .form file and the .java file.  Double clicking the Java file results in nothing happening.
Comment 5 JensHillert 2013-03-28 14:09:34 UTC
I have the same problem in Netbeans 7.3 when using a swing project:
ALT+SHIFT+O works fine if only a ".java" file exists, but it does not work when a ".java" and a ".form" extension exist for the given class name.
Comment 6 Milos Kleint 2013-04-15 06:12:02 UTC
appears to be working for me (correctly) equally in maven projects as in others (apisupport). reassigning back to utilities/jumpto.
Comment 7 JensHillert 2013-04-22 10:06:22 UTC
Tried again today with Netbeans 7.3 Patch 1 under RHEL 6.3 with SUN (i.e. Oracle) JDK 1.6.0. The project is a JAVA application and no maven project. It uses netbeans form files built with the netbeans GUI editor.

Opening java files works fine, if a java file is selected which has no form file assoiciated with it.
BUT:
Opening java files (or form files) does not work, if the typed name in the ALT+SHIFT+O dialog finds java and form files.
Comment 8 JensHillert 2013-04-22 10:17:27 UTC
Created attachment 133659 [details]
does-not-work-with-this-projekt.tar.gz

See the attached project:
javaapplication1 can be opened with ALT+SHIFT+O
newjpanel1 cannot be opened with ALT+SHIFT+O (has a form file)
Comment 9 JensHillert 2013-04-22 13:25:05 UTC
(In reply to comment #8)
> Created attachment 133659 [details]
> does-not-work-with-this-projekt

Sorry, this should have been named: "does-not-work-with-this-projekt.tar.gz"
Comment 10 Tomas Zezula 2013-06-07 07:55:51 UTC
Fixed jet-main 086fc39815ea


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo