Bug 227289 - Update version of requested java to run embedded WebView
Update version of requested java to run embedded WebView
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Embedded Browser
7.3
All All
: P3 (vote)
: 7.3.1
Assigned To: Stanislav Aubrecht
issues@platform
73patch2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-11 13:44 UTC by Antonin Nebuzelsky
Modified: 2013-05-09 13:51 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonin Nebuzelsky 2013-03-11 13:44:39 UTC
Update the text of the message inside the embedded browser's window to shorter and currently more correct:

  "Please specify the location of JDK 7u10 or newer."

Update the detection mechanism to automatically start WebView with

* Java 7u10 or newer Java 7 with FX,
* Java 8 builds with FX
Comment 1 Stanislav Aubrecht 2013-03-11 15:58:06 UTC
core-main 6dac4a62fbd7
Comment 2 Quality Engineering 2013-03-13 02:08:53 UTC
Integrated into 'main-golden', will be available in build *201303122300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/6dac4a62fbd7
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #227289 - Update version of requested java to run embedded WebView
Comment 3 Vladimir Riha 2013-04-08 08:50:05 UTC
I cannot try it since JDK 1.7+ is required to run IDE, but it works with JDK8 & JDK7. So verified



Product Version: NetBeans IDE Dev (Build web-main-10256-on-20130406)
Java: 1.8.0-ea; Java HotSpot(TM) Client VM 25.0-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b82
System: Linux version 3.2.0-39-generic-pae running on i386; UTF-8; en_US (nb)
Comment 4 Marian Mirilovic 2013-05-03 09:10:59 UTC
Standa, could you please backport this fix into release73 branch ? Thanks in advance.
Comment 5 Stanislav Aubrecht 2013-05-06 09:44:50 UTC
backported to release73 branch as 80a3cfd7f672
Comment 6 Quality Engineering 2013-05-07 00:18:41 UTC
Integrated into 'releases', will be available in build *201305062200* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/80a3cfd7f672
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #227289 - backport of 6dac4a62fbd7
Comment 7 Vladimir Riha 2013-05-09 13:51:11 UTC
patch2 verified

Product Version: NetBeans IDE 7.3.1 (Build 201302132200)
Java: 1.8.0-ea; Java HotSpot(TM) Client VM 25.0-b23
Runtime: Java(TM) SE Runtime Environment 1.8.0-ea-b82
System: Linux version 3.2.0-41-generic-pae running on i386; UTF-8; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo