Bug 227251 - 4: Failure
4: Failure
Status: RESOLVED DUPLICATE of bug 216366
Product: cnd
Classification: Unclassified
Component: execution
7.3
All All
: P3 (vote)
: TBD
Assigned To: Maria Tishkova
dlight-issues@cnd
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-10 08:21 UTC by Exceptions Reporter
Modified: 2013-05-17 13:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.26 KB, text/plain)
2013-03-10 08:21 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-03-10 08:21:49 UTC
This issue was reported manually by alexvsimon.
It already has 1 duplicates 


Build: NetBeans IDE 7.3 (Build 201302132200)
VM: Java HotSpot(TM) 64-Bit Server VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b11
OS: Windows 7

Stacktrace: 
4: Failure
   at com.jcraft.jsch.ChannelSftp.throwStatusError(ChannelSftp.java:2491)
   at com.jcraft.jsch.ChannelSftp.mkdir(ChannelSftp.java:1897)
   at org.netbeans.modules.nativeexecution.api.util.HelperUtility.getPath(HelperUtility.java:181)
   at org.netbeans.modules.nativeexecution.api.util.HelperUtility.getPath(HelperUtility.java:100)
   at org.netbeans.modules.nativeexecution.NbNativeProcess.<init>(NbNativeProcess.java:81)
   at org.netbeans.modules.nativeexecution.NbRemoteNativeProcess.<init>(NbRemoteNativeProcess.java:57)
Comment 1 Exceptions Reporter 2013-03-10 08:21:51 UTC
Created attachment 132420 [details]
stacktrace
Comment 2 Maria Tishkova 2013-05-17 10:02:47 UTC
moved to execution sub-component as dlight is gone from the NetBeans
Comment 3 Maria Tishkova 2013-05-17 13:45:26 UTC
From messages.log:

WARNING [nativeexecution.support.logger]: [12844 ms.] UnixHostInfoProvider: mkdir: cannot create directory `/var/tmp/dlight_chamindaa/eab3ae9f': No space left on device
WARNING [nativeexecution.support.logger]: [12844 ms.] UnixHostInfoProvider: Warning: /var/tmp/dlight_chamindaa/eab3ae9f is not writable
WARNING [nativeexecution.support.logger]: [12844 ms.] UnixHostInfoProvider: Warning: /var/tmp/dlight_chamindaa/eab3ae9f_1 is not writable
WARNING [nativeexecution.support.logger]: [13656 ms.] UnixHostInfoProvider: Warning: /var/tmp/dlight_chamindaa/eab3ae9f_2 is not writable
WARNING [nativeexecution.support.logger]: [13656 ms.] UnixHostInfoProvider: Warning: /var/tmp/dlight_chamindaa/eab3ae9f_3 is not writable
WARNING [nativeexecution.support.logger]: [13656 ms.] UnixHostInfoProvider: Warning: /var/tmp/dlight_chamindaa/eab3ae9f_4 is not writable
WARNING [nativeexecution.support.logger]: [15875 ms.] Failed to upload pty
WARNING [nativeexecution.support.logger]: [15875 ms.] File /var/tmp/dlight_chamindaa/01179411153/pty doesnt exist, and cannot be uploaded. Do you have enough privileges?
WARNING [nativeexecution.support.logger]: [15875 ms.] You could try to use -J-Dcnd.tmpbase=<other base location> to re-define default one.


So from what I see:
1. check if you can  mkdir  /var/tmp/dlight_chamindaa/eab3ae9f
2. You could try to use option when starting IDE -J-Dcnd.tmpbase=<other base location> to re-define default one.

*** This bug has been marked as a duplicate of bug 216366 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo