Bug 226889 - Some menu items are completely blank white nothing!!!
Some menu items are completely blank white nothing!!!
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Window System
7.3
PC Linux
: P2 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
: I18N, UI, USABILITY
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-01 12:13 UTC by the-jupiter
Modified: 2013-03-04 09:31 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (23.85 KB, text/plain)
2013-03-01 12:13 UTC, the-jupiter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description the-jupiter 2013-03-01 12:13:14 UTC
Product Version = NetBeans IDE 7.3 (Build 201302132200)
Operating System = Linux version 3.5.0-17-generic running on i386
Java; VM; Vendor = 1.7.0_15
Runtime = OpenJDK Client VM 23.7-b01

I am running netbeans using "export LANG=C" to get it to use the US English locale.
Some (half?) of the menus appear completely WHITE.
THIS IS NOT THE BAD FONTS APPEAR AS SQUARES IN JAPANESE!!!

I mean you look and the text is totally appears to not be there UNTIL you hover the mouse over those items -- when you do that the text becomes visible because of the highlight over the menu item.  On my system, the highlight appears to be green or something with the text white.  And the text is in English as exspected.

The result: Netbeans is 100% unusable.
I can't even begine to reasonably do anything with it now.

I do have pretty much all Japanese fonts installed on my system.
I even tried the "ln -s /etc/alternatives/some_font.ttf" thing recommend on the netbeans site and it had no effect.

Please fix.

Please keep me in the loop.

Thanks.
Comment 1 the-jupiter 2013-03-01 12:13:19 UTC
Created attachment 132064 [details]
IDE log
Comment 2 Stanislav Aubrecht 2013-03-04 09:31:57 UTC
Please run SwingSet demo app (or any other plain swing app) with the same JDK setup and check how the menu looks like in the application.
Also please provide a screen shot and try to reproduce the problem with the latest version of Oracle JDK 1.7 and reopen, thanks.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo