Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 226449 - Making errors in JPA NamedQueries more visible
Making errors in JPA NamedQueries more visible
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Persistence
7.3
PC Windows 7
: P3 with 3 votes (vote)
: TBD
Assigned To: Sergey Petrov
issues@javaee
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-21 10:27 UTC by mienamoo
Modified: 2016-07-07 08:55 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Current view of named query with issue (13.68 KB, image/png)
2013-02-21 10:28 UTC, mienamoo
Details
Proposed view of named query with issue (13.70 KB, image/png)
2013-02-21 10:28 UTC, mienamoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2013-02-21 10:27:32 UTC
It would be very helpful if errors in @NamedQuery annotations could be underlined. The information is available to the IDE, since a hint is displayed on the class. (See first screenshot.) However, it would be so much easier to see what is wrong if the issue could be underlined. (See second screenshot with proposal.)
Comment 1 mienamoo 2013-02-21 10:28:03 UTC
Created attachment 131662 [details]
Current view of named query with issue
Comment 2 mienamoo 2013-02-21 10:28:35 UTC
Created attachment 131663 [details]
Proposed view of named query with issue
Comment 3 Martin Balin 2016-07-07 08:55:28 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo