Bug 226438 - IllegalArgumentException: Parameter file was not normalized. Was /Users/shotskiy/NetBeansProjects/fanclubgwc/../.. instead of /Users/shotskiy
IllegalArgumentException: Parameter file was not normalized. Was /Users/shots...
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-21 08:38 UTC by Exceptions Reporter
Modified: 2013-07-09 10:05 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (887 bytes, text/plain)
2013-02-21 08:38 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-02-21 08:38:40 UTC
This bug was originally marked as duplicate of bug 161096, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.12-b01-434, Java(TM) SE Runtime Environment, 1.6.0_37-b06-434-11M3909
OS: Mac OS X

Stacktrace: 
java.lang.IllegalArgumentException: Parameter file was not normalized. Was /Users/shotskiy/NetBeansProjects/fanclubgwc/../.. instead of /Users/shotskiy
   at org.openide.filesystems.FileUtil.toFileObject(FileUtil.java:1055)
   at org.openide.filesystems.FileUtil$Holder.locateCurrent(FileUtil.java:451)
   at org.openide.filesystems.FileUtil$Holder.someChange(FileUtil.java:486)
   at org.openide.filesystems.FileUtil$Holder.fileFolderCreated(FileUtil.java:554)
   at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEventImpl(FCLSupport.java:142)
   at org.openide.filesystems.FCLSupport$DispatchEventWrapper.dispatchEvent(FCLSupport.java:128)
Comment 1 Exceptions Reporter 2013-02-21 08:38:42 UTC
Created attachment 131655 [details]
stacktrace
Comment 2 Jaroslav Tulach 2013-07-09 10:05:55 UTC
Too old report. The code has been moved to FileChangeImpl in 7.3 or sooner.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo