Bug 225620 - Creating a top component causes the IDE to hang
Creating a top component causes the IDE to hang
Status: RESOLVED DUPLICATE of bug 226913
Product: platform
Classification: Unclassified
Component: Data Systems
7.3
All All
: P1 with 2 votes (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
: REGRESSION
: 226095 227336 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-01 03:58 UTC by manikantannaren
Modified: 2013-04-19 06:26 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
The Netbeans IDE Log (49.90 KB, application/octet-stream)
2013-02-01 07:14 UTC, manikantannaren
Details
The Netbeans IDE Threaddump (89.51 KB, text/plain)
2013-02-01 07:15 UTC, manikantannaren
Details
nb thread dump (34.43 KB, text/plain)
2013-03-08 15:06 UTC, Martin Kozeny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manikantannaren 2013-02-01 03:58:18 UTC
[ BUILD # : 201301310001 ]
[ JDK VERSION : 1.6.37 ]

1. Create a New Netbeans module project
2. Select Window from the modules file wizard
3. Choose any option from the  Window Position drop down
4. Provide the values in the next step
5. Click Finish
6. The Dilog just stays.

The .form file is created but is of zero bytes. I believe that is what is
causing the problem.
Comment 1 swpalmer 2013-02-01 04:05:52 UTC
Does this happen with JDK 7u11?
Comment 2 manikantannaren 2013-02-01 06:08:42 UTC
Yes I could replicate with JDK 7u11
Comment 3 ehsavoie 2013-02-01 06:23:47 UTC
I don't reproduce it with 7.3 RC 1 on GNU/Linux (KDE)
Comment 4 mienamoo 2013-02-01 06:32:09 UTC
I was not able to reproduce this on Windows 7, JDK 7u11, NetBeans build 201301310001.

Could you please have a look in the IDE log to see whether there is any relevant information available there?
Comment 5 manikantannaren 2013-02-01 07:11:33 UTC
There is no information after "indexing of the project took....".
Comment 6 manikantannaren 2013-02-01 07:14:31 UTC
Created attachment 130916 [details]
The Netbeans IDE Log
Comment 7 manikantannaren 2013-02-01 07:15:39 UTC
Created attachment 130917 [details]
The Netbeans IDE Threaddump
Comment 8 manikantannaren 2013-02-01 07:16:45 UTC
Couple of Netcat73 have also tested this on other OS and have not reported a problem. This is local to Mac only
Comment 9 manikantannaren 2013-02-04 06:32:33 UTC
With the last build - NetBeans IDE Dev (Build 201302030001), I dont see this behavior.
Comment 10 mienamoo 2013-03-06 13:17:45 UTC
I saw this once this week with build 201302132200 on JDK 7u13 64-bit, Windows 7. I created a brand new Ant-based platform application, and one module. And then the wizard just never completed. After creating a second module, I could create windows in both the first and second.

Potential factors that could have contributed, are switching to a new project group and creating the new window very soon after the project (scanning was potentially still in progress).

This part of my original log file could be of use. The file called bla.java (POJO) below was in the project group that I was switching away from. Didn't see this again in subsequent runs of the IDE when the creation failed though.


INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Complete indexing of 8 source roots took: 3,276 ms (New or modified files: 1, Deleted files: 0) [Adding listeners took: 2 ms]
INFO [org.netbeans.spi.lexer.MutableTextInput]: !!WARNING!! Missing READ-LOCK when accessing TokenHierarchy: input-source:org.netbeans.modules.editor.NbEditorDocument@348b8d45, mimeType='text/x-java', kitClass=null, length=2243, version=9, file=org.netbeans.modules.java.JavaDataObject@358d5032[C:\Projects\bla.java@9f26fb4d:65aec411]
java.lang.Exception
	at org.netbeans.lib.lexer.TokenHierarchyOperation.ensureReadLocked(TokenHierarchyOperation.java:397)
	at org.netbeans.lib.lexer.TokenHierarchyOperation.tokenSequence(TokenHierarchyOperation.java:422)
	at org.netbeans.lib.lexer.TokenHierarchyOperation.tokenSequence(TokenHierarchyOperation.java:418)
	at org.netbeans.api.lexer.TokenHierarchy.tokenSequence(TokenHierarchy.java:186)
	at org.netbeans.api.java.source.SourceUtils.getJavaTokenSequence(SourceUtils.java:149)
...
Comment 11 mienamoo 2013-03-06 13:20:59 UTC
And then a few minutes ago, a colleague showed me that he was experiencing this same issue with build 201302132200, on Windows 8, JDK 7u9 64-bit. In a Maven-based application.

This part of his log file might be relevant:


INFO [org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater]: Complete indexing of 17 source roots took: 1,932 ms (New or modified files: 2, Deleted files: 0) [Adding listeners took: 12 ms]
INFO [org.netbeans.core.ui.focus]: External Changes Refresh on focus gain disabled
WARNING [org.netbeans.TopSecurityManager]: use of system property netbeans.user has been obsoleted in favor of InstalledFileLocator/Places at org.netbeans.modules.tomcat5.util.TomcatProperties.<init>(TomcatProperties.java:210)
WARNING [org.netbeans.TopSecurityManager]: use of system property netbeans.user has been obsoleted in favor of InstalledFileLocator/Places at org.netbeans.modules.keyring.impl.Utils.goMinusR(Utils.java:75)
INFO [org.netbeans.modules.refactoring.spi.impl.ParametersPanel]: org.netbeans.modules.refactoring.api.RefactoringSession@42733a2e called start multiple times
Comment 12 Martin Kozeny 2013-03-06 13:41:42 UTC
*** Bug 226095 has been marked as a duplicate of this bug. ***
Comment 13 Chiana 2013-03-06 14:14:05 UTC
Me too in 201303032300

If it does not happen when creating the first window it will when creating the second, and also you cannot take a dump or a profile as the dialog window seems to be application-modal.

My suggestion is that this is either p2 or p1
Comment 14 MackSix 2013-03-06 14:27:35 UTC
I can repeat it every time if I choose "Window Position: editor" and "Open on Application Start". 

This does not happen in 7.2.1. 

Product Version: NetBeans IDE 7.3 (Build 201302132200)
Java: 1.7.0_15; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_15-b03
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 15 Chiana 2013-03-06 14:31:26 UTC
Seems this is independant of operating system, just saw it in Linux under KDE too...
Comment 16 MackSix 2013-03-06 14:37:05 UTC
It happens on latest Dev build.

Product Version: NetBeans IDE Dev (Build 201303052300)
Java: 1.7.0_15; Java HotSpot(TM) 64-Bit Server VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_15-b03
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)
Comment 17 Chiana 2013-03-06 14:39:45 UTC
Yes, I know that, but why do you change platform back to Mac? This happens on all platforms
Comment 18 MackSix 2013-03-06 14:41:12 UTC
When I add comments, it is changing Priority and Platform fields back if someone changed them after I viewed the bug. There seems to be a bug in bugzilla. :)
Comment 19 Chiana 2013-03-06 14:44:34 UTC
No, you just select "post my new comment only" on the "Mid-air collission" screen.
Comment 20 MackSix 2013-03-06 14:47:45 UTC
(In reply to comment #19)
> No, you just select "post my new comment only" on the "Mid-air collission"
> screen.

I never got mid-air collision warning.
Comment 21 Chiana 2013-03-06 14:50:57 UTC
Hmm... seems there is a bug in bugzilla B-)
Comment 22 MackSix 2013-03-06 15:11:58 UTC
Is there an expiration time for mid-air collisions? Maybe it had elapsed? (In reply to comment #21)
> Hmm... seems there is a bug in bugzilla B-)

Is there an expiration time for mid-air collisions? Maybe it had elapsed?
Comment 23 Chiana 2013-03-06 15:13:54 UTC
Don't know about any timeout's...

But I have a process-dump from taskmanager of hanging IDE, if it is of any use I upload it somewhere, it's about 98 med compressed...
Comment 24 mienamoo 2013-03-06 16:56:41 UTC
Thanks for all the additional feedback!

I believe that this is important enough to go into 7.3 patch 1.
Comment 25 cdavis 2013-03-06 20:08:55 UTC
(In reply to comment #24)
> Thanks for all the additional feedback!
> 
> I believe that this is important enough to go into 7.3 patch 1.  

It's more than "important"....it's critical...a show stopper!(In reply to comment #24)
> Thanks for all the additional feedback!
> 
> I believe that this is important enough to go into 7.3 patch 1.
Comment 26 Martin Kozeny 2013-03-08 15:06:34 UTC
Created attachment 132385 [details]
nb thread dump
Comment 27 Martin Kozeny 2013-03-08 15:09:16 UTC
this bug does not belong to apisupport according to this thread dump http://bugzilla-attachments-225620.netbeans.org/bugzilla/attachment.cgi?id=132385 so I am passing it to platform
Comment 28 Marian Mirilovic 2013-03-13 17:37:36 UTC
Jarda, Tonda
this is P1 & regression & we have to fix it in Patch 1, so please react ASAP. Thanks in advance.
Comment 29 Jaroslav Tulach 2013-03-15 12:10:02 UTC
Looks like the deadlock is the same as the one in bug 226913 (however just knowing this does not get us closer to fix it).

*** This bug has been marked as a duplicate of bug 226913 ***
Comment 30 Tomas Danek 2013-03-15 14:23:41 UTC
Duplicate issue was fixed, could reporter (or someone on CC who was able to reproduce) verify once fix of issue 226913 becomes available in dev build? (There will be a notification in issue 226913 with link to build where fix is available). Thanks in advance.
Comment 31 Martin Kozeny 2013-03-18 08:19:02 UTC
*** Bug 227336 has been marked as a duplicate of this bug. ***
Comment 32 mienamoo 2013-03-22 07:02:36 UTC
Verified with build 201303212300. Thanks!
Comment 33 mienamoo 2013-04-19 06:26:52 UTC
Verified with NetBeans IDE 7.3.1 (Build 201304162201).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo