Bug 225494 - Team>Export Diff patch is not generating the file
Team>Export Diff patch is not generating the file
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.3
PC Windows 7
: P2 (vote)
: 7.4
Assigned To: Ondrej Vrabec
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 19:33 UTC by javydreamercsw
Modified: 2014-04-08 20:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (65.53 KB, text/plain)
2013-01-29 19:33 UTC, javydreamercsw
Details
Requested screenshot (15.19 KB, image/png)
2013-01-29 23:16 UTC, javydreamercsw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2013-01-29 19:33:26 UTC
Product Version = NetBeans IDE 7.3 RC1 (Build 201301240957)
Operating System = Windows 7 version 6.1 running on x86
Java; VM; Vendor = 1.7.0_11
Runtime = Java HotSpot(TM) Client VM 23.6-b04


I have a project on SVN and tried to export a patch of WIP changes before reverting to generate a build out of it. Even though the output window states it's done (Jan 29, 2013 1:30:58 PM Exporting "Project Name" Diff Patch finished.)  the file is never created and/or opened in the editor as it uses to. Looks like a regression of some sort.
Comment 1 javydreamercsw 2013-01-29 19:33:30 UTC
Created attachment 130801 [details]
IDE log
Comment 2 javydreamercsw 2013-01-29 19:34:49 UTC
Process was successful when attempted from Tortoise svn.
Comment 3 Ondrej Vrabec 2013-01-29 20:55:23 UTC
> INFO [org.netbeans.modules.subversion]: Diff patch export failed!
> java.io.FileNotFoundException: Z:\NetBeans\SynamicD-Wrapper\branches\1.x branch\SynamicD\SynamicD\temp (The system cannot find the file specified)
> 	at java.io.FileInputStream.open(Native Method)
> 	at java.io.FileInputStream.<init>(FileInputStream.java:138)
> 	at org.netbeans.modules.subversion.ui.diff.DiffStreamSource.init(DiffStreamSource.java:227)
> Caused: java.io.IOException: Can not load remote file for Z:\NetBeans\SynamicD-Wrapper\branches\1.x branch\SynamicD\SynamicD\temp

Is Z:\NetBeans\SynamicD-Wrapper\branches\1.x branch\SynamicD\SynamicD\temp part of the changes you wanted to commit? What is its status? Is it a folder? Can you make a screenshot of the current changes (Subversion -> Show Changes) you want to export?
Comment 4 javydreamercsw 2013-01-29 22:36:17 UTC
Temp folder was not part of the export. Was a folder that existed long ago. Sometime in the IDE session back then but was not there when I tried to export. I'll get that screenshot ASAP.
Comment 5 javydreamercsw 2013-01-29 23:16:05 UTC
Created attachment 130802 [details]
Requested screenshot
Comment 6 Ondrej Vrabec 2013-01-30 14:54:53 UTC
> Temp folder was not part of the export. Was a folder that existed long ago. Sometime in the IDE session back then but was not there when I tried to export.
But from the log it seems that the export failed because of that. Can you try again and check the log for an error message and let me know if it fails because of the same file/folder?
Comment 7 Ondrej Vrabec 2013-01-30 16:01:22 UTC
I was able to reproduce. This happens simply because you deleted the folder externally and the IDE SVN support still considered it present. So true, there's a bug and i will fix it, but it wouldn't happen if you sync IDE cache with external changes (Subversion -> Show Changes).
Comment 8 Ondrej Vrabec 2013-01-30 16:10:38 UTC
fix: http://hg.netbeans.org/core-main/rev/430e063d5ff2
Comment 9 Quality Engineering 2013-02-02 02:34:20 UTC
Integrated into 'main-golden', will be available in build *201302020001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/430e063d5ff2
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #225494 - Team>Export Diff patch is not generating the file
excluding folders, they make no sense in our patches anyway


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo