Bug 225477 - The whole table is refreshed when a node is inserted.
The whole table is refreshed when a node is inserted.
Status: RESOLVED DUPLICATE of bug 227183
Product: platform
Classification: Unclassified
Component: Outline&TreeTable
7.3
All All
: P3 with 1 vote (vote)
: 7.4
Assigned To: Martin Entlicher
issues@platform
: PERFORMANCE, REGRESSION
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-29 14:06 UTC by Martin Entlicher
Modified: 2014-01-21 11:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Table refresh stack. (4.40 KB, text/plain)
2013-01-29 14:06 UTC, Martin Entlicher
Details
The table is refreshed as well when column names change. (803 bytes, text/plain)
2013-01-29 15:35 UTC, Martin Entlicher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Entlicher 2013-01-29 14:06:28 UTC
Created attachment 130787 [details]
Table refresh stack.

This seems to be some regression in Outline. After a node is inserted, the whole table is refreshed as illustrates the attached stack trace.
This can also worsen performance of Outline.
(This was found during examination of issue #225452.)
Comment 1 Martin Entlicher 2013-01-29 15:35:52 UTC
Created attachment 130794 [details]
The table is refreshed as well when column names change.
Comment 2 Martin Entlicher 2013-06-05 13:47:58 UTC
Changing to P3 - this does not seem to be as severe as an average P2 defect.
Still it's targeted to be solved in 7.4.
Comment 3 Jaroslav Havlin 2014-01-21 11:32:51 UTC

*** This bug has been marked as a duplicate of bug 227183 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo