Bug 225288 - 70s - YAGL(?) in ChildrenCache.refresh
70s - YAGL(?) in ChildrenCache.refresh
Status: RESOLVED DUPLICATE of bug 228470
Product: platform
Classification: Unclassified
Component: Filesystems
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-24 14:08 UTC by Exceptions Reporter
Modified: 2013-07-25 12:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (856.33 KB, application/nps)
2013-01-24 14:08 UTC, Exceptions Reporter
Details
nps snapshot (48.58 KB, application/nps)
2013-01-24 16:19 UTC, Alexander Simon
Details
nps snapshot (11.22 KB, application/nps)
2013-02-11 09:04 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2013-01-24 14:08:21 UTC
Build: NetBeans IDE 7.3 Beta 2 (Build 201211062253)
VM: Java HotSpot(TM) Client VM, 23.6-b04, Java(TM) SE Runtime Environment, 1.7.0_11-b21
OS: Windows 7

User Comments:
GUEST: opening javascript file with navigator panel opened

vv159170: popup menu for folder in Favorites

vv159170: hover Tools or Properties context items for folder in Favorites view



Maximum slowness yet reported was 70643 ms, average is 29171
Comment 1 Exceptions Reporter 2013-01-24 14:08:36 UTC
Created attachment 130587 [details]
nps snapshot
Comment 2 Alexander Simon 2013-01-24 16:19:43 UTC
Created attachment 130596 [details]
nps snapshot
Comment 3 Jaroslav Tulach 2013-01-29 09:52:52 UTC
cnd.makeproject.MakeProjectFileOwnerQuery.getOwner()	100.0	15,900 ms (100%)

calls 

org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObjectFactory.getFileObject()	100.0	15,900 ms 

which blocks on mutex that is probably held by

org.netbeans.modules.masterfs.filebasedfs.children.ChildrenSupport.rescanChild()	100.0	15,900 ms (100%)
Comment 4 Exceptions Reporter 2013-02-11 09:04:46 UTC
Created attachment 131226 [details]
nps snapshot
Comment 5 Jaroslav Havlin 2013-07-25 12:56:31 UTC

*** This bug has been marked as a duplicate of bug 232886 ***
Comment 6 Jaroslav Havlin 2013-07-25 12:58:57 UTC
(In reply to comment #5)
> *** This bug has been marked as a duplicate of bug 232886 ***
I'm sorry, wrong bug number. Correct is bug 228470.

*** This bug has been marked as a duplicate of bug 228470 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo