Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 224908 - Can't pause NiosII GDB which uses SIGTRAP
Can't pause NiosII GDB which uses SIGTRAP
Status: RESOLVED DUPLICATE of bug 224840
Product: cnd
Classification: Unclassified
Component: Debugger
7.4
PC Linux
: P3 (vote)
: TBD
Assigned To: henk89
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-15 13:17 UTC by Arkona_MatthiasMann
Modified: 2013-04-30 13:41 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Debug Console from Netbeans (4.33 KB, text/x-log)
2013-01-15 13:17 UTC, Arkona_MatthiasMann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arkona_MatthiasMann 2013-01-15 13:17:43 UTC
Created attachment 130233 [details]
Debug Console from Netbeans

I'm using Netbeans on Linux to debug a NiosII (Softcore CPU from Altera) system.

Product Version: NetBeans IDE Dev (Build 201301120001)
Java: 1.7.0_11; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
System: Linux version 2.6.38-16-generic running on amd64; UTF-8; de_DE (nb)

This uses a nios2-gdb-server which maintains the JTAG connection, and a nios2-elf-gdb together with the gdbserver plugin of Netbeans. The attach command is "remote 127.0.0.1:1234".

The problem is that the pause button in Netbeans does not work.
When I manually send a "kill -s INT <pid-of-nios2-elf-gdb>" Netbeans shows a "DS1008.elf - Signal Caught" pop up:
Signal received: SIGTRAP (Trace/breakpoint trap)
For program DS1008.elf, pid -1

After pressing "Discard & Pause" the program is paused and I can debug it as expected.

This might be similar to bug 224840
Comment 1 Egor Ushakov 2013-04-30 13:41:05 UTC
really a duplicate, let's keep all comments regarding the issue in one place, I will add a reference into bug 224840

*** This bug has been marked as a duplicate of bug 224840 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo