Bug 224866 - NetBeans stops being able to receive keyboard input
NetBeans stops being able to receive keyboard input
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: JDK Problems
7.3
PC Linux
: P2 with 1 vote (vote)
: 7.4
Assigned To: Antonin Nebuzelsky
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-14 18:19 UTC by recurse
Modified: 2013-06-21 14:28 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (48.70 KB, text/plain)
2013-01-14 18:19 UTC, recurse
Details
Thread dump generated using ctrl-\ (19.25 KB, text/plain)
2013-01-15 18:32 UTC, recurse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description recurse 2013-01-14 18:19:39 UTC
Product Version = NetBeans IDE 7.3 Beta 2 (Build 201211062253)
Operating System = Linux version 3.6.11-1.fc17.x86_64 running on amd64
Java; VM; Vendor = 1.7.0_09
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.5-b02

I often get this problem. After using NetBeans for a while (several seconds to a few minutes), it sometimes stops being able to receive keyboard input. Everything else seems normal, including mouse input and the response to it. It seems that a similar issue has appeared in previous versions before but supposedly fixed. I can link to those issues if necessary. I don't have a reliable way of reproducing this but it happens a lot and is the reason I have to close NetBeans >50% of the time.
Comment 1 recurse 2013-01-14 18:19:44 UTC
Created attachment 130197 [details]
IDE log
Comment 2 Antonin Nebuzelsky 2013-01-15 13:00:59 UTC
Please, attach a full thread dump generated when the problems appears to this issue and reopen. Thanks.
http://wiki.netbeans.org/GenerateThreadDump
Comment 3 recurse 2013-01-15 18:32:13 UTC
Created attachment 130255 [details]
Thread dump generated using ctrl-\
Comment 4 Antonin Nebuzelsky 2013-01-18 14:44:42 UTC
The thread dump does not seem to point to the problem.

Possibly the two exceptions in the messages.log could help indicate the cause.

INFO [org.netbeans.spi.lexer.MutableTextInput]: !!WARNING!! Missing READ-LOCK when accessing TokenHierarchy: ...

INFO [dlight.libs.common.logger]: Should not be called from UI thread

Reassigning to editor for evaluation.
Comment 5 Stanislav Aubrecht 2013-01-18 14:53:32 UTC
Reporter, is there blinking cursor when clicking into editor window?
Does it affect the editor window only or other text fields as well?
Does the IDE react to keyboard shortcuts? e.g. Ctrl+Tab?
Comment 6 recurse 2013-01-20 11:12:59 UTC
Yes, there's a blinking cursor, and I can even make selections with the mouse.

As far as I can tell, nothing at all responds to the keyboard but everything responds to the mouse. Ctrl-tab doesn't work. Alt-F also doesn't work, though I can still bring out the "open file" dialog with the mouse, but the dialog that pops up doesn't respond to the keyboard, either.
Comment 7 Stanislav Aubrecht 2013-01-21 09:57:44 UTC
Looks like a JDK problem but without reliable steps to reproduce it'll next to impossible to fix...
Comment 8 Miloslav Metelka 2013-01-21 10:45:19 UTC
Sorry, but the lexer warning could only lead to some shifted offsets but it certainly does not cause this focus related problem so editor/lexer category is wrong. As Standa pointed out this looks like a JDK problem so reassigning there.
Comment 9 Stanislav Aubrecht 2013-01-22 09:12:15 UTC
There is another keyboard input related issue: http://netbeans.org/bugzilla/show_bug.cgi?id=225115
Comment 10 Antonin Nebuzelsky 2013-06-21 14:28:35 UTC
Which window manager are you using in your Linux setup?

The following JDK bug describes such problems with enlightment window manager:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8009224

If that's the case, can you confirm that last JDK8 builds work for you without the problem?
https://jdk8.java.net/download.html


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo