Bug 224757 - NPE from o.n.m.autoupdate.ui.actions.AutoupdateSettings.getSuperIdentity when starting CRUD sample
NPE from o.n.m.autoupdate.ui.actions.AutoupdateSettings.getSuperIdentity when...
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Templates
7.3
PC Mac OS X
: P2 (vote)
: 7.3
Assigned To: Martin Kozeny
issues@apisupport
: 73_HR_FIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-11 13:06 UTC by Tomas Danek
Modified: 2013-01-21 15:30 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2013-01-11 13:06:26 UTC
Product Version: NetBeans IDE 7.3 RC1 (Build 201301102100)
Java: 1.7.0_10; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_10-b18
System: Mac OS X version 10.8.2 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.3rc1
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.3rc1

------------------------------------
- create new Maven CRUD sample app
- clean and build, run

NPE during platform launch; did not reproduce on other machine with Ubuntu.
--------8<-----------
WARNING [org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings]: The property "netbeans.default_userdir_root" was not set!
SEVERE [org.netbeans.core.modules]
java.lang.NullPointerException
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.getSuperIdentity(AutoupdateSettings.java:435)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateSettings.generateIdentity(AutoupdateSettings.java:136)
	at org.netbeans.modules.autoupdate.ui.actions.AutoupdateCheckScheduler.signOn(AutoupdateCheckScheduler.java:110)
	at org.netbeans.modules.autoupdate.ui.actions.Installer.restored(Installer.java:63)
	at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:469)
[catch] at org.netbeans.core.startup.NbInstaller.loadImpl(NbInstaller.java:392)
Comment 1 Tomas Danek 2013-01-11 14:22:17 UTC
this seems to be general problem of all apps built on top of 7.2.1 -> I reproduce the NPE when I create new Maven NetBeans application. Any idea what might be wrong?
Comment 2 Tomas Danek 2013-01-11 14:23:38 UTC
CCing Jirka, since he may have insight what is AU code trying to achieve.
Comment 3 Jiri Rechtacek 2013-01-15 19:07:23 UTC
Tomas, could you run the application with switch -J-Dorg.netbeans.modules.autoupdate.ui.actions.level=-1 and attach the log? Thanks
Comment 4 Jiri Rechtacek 2013-01-15 19:11:01 UTC
Milos, what version of NetBeans Platform archetype is currently stored in the Maven repository - the default in 7.3rc1? When will be publish a newer archetype? Thanks
Comment 5 Milos Kleint 2013-01-15 19:15:41 UTC
what do you mean, jrechtacek? You want the version of the archetype or version of netbeans? in the archetype, the version of netbeans is variable that the user is asked about in the wizard associated in that archetype..
Comment 6 Jiri Rechtacek 2013-01-15 20:03:54 UTC
(In reply to comment #5)
> what do you mean, jrechtacek? You want the version of the archetype or version
> of netbeans? in the archetype, the version of netbeans is variable that the
> user is asked about in the wizard associated in that archetype..

Okay, my question was where the property <version>${netbeans.version}</version> in CRUD application's pom.xml comes from?
Comment 7 Jiri Rechtacek 2013-01-15 20:17:00 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > what do you mean, jrechtacek? You want the version of the archetype or version
> > of netbeans? in the archetype, the version of netbeans is variable that the
> > user is asked about in the wizard associated in that archetype..
> 
> Okay, my question was where the property <version>${netbeans.version}</version>
> in CRUD application's pom.xml comes from?

I found it - MavenCRUDSample/pom.xml contains 
===
    <properties>
        <netbeans.version>RELEASE721</netbeans.version>
        <brandingToken>crudsample</brandingToken>
        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
    </properties>
===
what's wrong. I should be increased to 7.3 (where the original bug was fixed) I guess.
Comment 8 Milos Kleint 2013-01-16 06:11:50 UTC
7.3 will be made available on the servers only at the time 7.3 is released. Meaning we would have to depend on beta artifacts in this case?
Comment 9 Jiri Rechtacek 2013-01-16 15:02:56 UTC
Martin, please change the netbeans version to <netbeans.version>RELEASE73</netbeans.version> on release73 branch. The NetBeans artifacts should be in the server once NB7.3 come out. Thank you
Comment 10 Martin Kozeny 2013-01-18 10:29:16 UTC
https://hg.netbeans.org/core-main/rev/8a7c4f944502
Comment 11 Jiri Rechtacek 2013-01-18 10:47:12 UTC
(In reply to comment #10)
> https://hg.netbeans.org/core-main/rev/8a7c4f944502

Good. Martin, please continue in the branch release73 just by changing netbeans.version in maven.samples/samples_src/MavenCRUDSample/pom.xml to RELEASE73 for the final release. Thanks
Comment 12 Milos Kleint 2013-01-18 16:03:45 UTC
http://hg.netbeans.org/releases/rev/67fee10cbc86
Comment 13 Quality Engineering 2013-01-19 00:03:22 UTC
Integrated into 'releases', will be available in build *201301182100* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/67fee10cbc86
User: Milos Kleint <mkleint@netbeans.org>
Log: #224757 use RELEASE73 in CRUD example, RELEASE721 contains a bug
Comment 14 Quality Engineering 2013-01-19 02:51:05 UTC
Integrated into 'main-golden', will be available in build *201301190001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8a7c4f944502
User: Martin Kozeny <mkozeny@netbeans.org>
Log: #224757: Changing the NetBeans version to RELEASE73-BETA2 in pom.xml in Maven CRUD sample.
Comment 15 Tomas Danek 2013-01-21 15:30:57 UTC
verified in 

Product Version: NetBeans IDE 7.3 RC1 (Build 201301202100)
Java: 1.7.0_11; Java HotSpot(TM) 64-Bit Server VM 23.6-b04
Runtime: Java(TM) SE Runtime Environment 1.7.0_11-b21
System: Mac OS X version 10.8.2 running on x86_64; US-ASCII; en_US (nb)
User directory: /Users/tomas/Library/Application Support/NetBeans/7.3rc1
Cache directory: /Users/tomas/Library/Caches/NetBeans/7.3rc1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo