Bug 223547 - I created a test class, tried to access a public method and get a package "..." does not exist error
I created a test class, tried to access a public method and get a package ".....
Status: RESOLVED INVALID
Product: java
Classification: Unclassified
Component: Project
7.2.1
PC Linux
: P3 (vote)
: TBD
Assigned To: Tomas Zezula
issues@java
: PLATFORM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-09 12:48 UTC by JUlrich22
Modified: 2012-12-10 12:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (95.87 KB, text/plain)
2012-12-09 12:48 UTC, JUlrich22
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JUlrich22 2012-12-09 12:48:18 UTC
Product Version = NetBeans IDE 7.2.1 (Build 201210100934)
Operating System = Linux version 3.2.0-29-generic running on amd64
Java; VM; Vendor = 1.7.0_07
Runtime = Java HotSpot(TM) 64-Bit Server VM 23.3-b01

public class NodeProcessor {
    
    NewClass nc = new NewClass();
    nc.setTest("TestOK");
}

public class NewClass {
    private String test;
    
    public void setTest(String str){
        test = str;
    }
    
}

Botch classes are in the same package.
Comment 1 JUlrich22 2012-12-09 12:48:35 UTC
Created attachment 129104 [details]
IDE log
Comment 2 Jiri Prox 2012-12-10 12:42:44 UTC
There is syntax error in you code. The two lines in the NodeProcessor class are not placed in method body.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo