Bug 222711 - Failing to download harness and platform via Ant script
Failing to download harness and platform via Ant script
Status: VERIFIED FIXED
Product: apisupport
Classification: Unclassified
Component: Harness
7.3
PC Windows 7
: P1 (vote)
: 7.3
Assigned To: Jaroslav Tulach
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-25 15:03 UTC by mienamoo
Modified: 2012-12-04 05:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mienamoo 2012-11-25 15:03:36 UTC
NetBeans build 201211200002
JDK 7u4 64-bit

This is a regression, hence the P1 classification. I was running through the test spec [1]. Both tests fail, due to the following error:

C:\Users\Hermien\Documents\NetBeansProjects\Tests\MyApp1\build.xml:7: The following error occurred while executing this line:
C:\Users\Hermien\Documents\NetBeansProjects\Tests\MyApp1\nbproject\build-impl.xml:41: The following error occurred while executing this line:
C:\Users\Hermien\Documents\NetBeansProjects\Tests\MyApp1\nbproject\platform.xml:29: No enum constant org.netbeans.nbbuild.AutoUpdateCatalogParser.ELEMENTS.content_description

If I change the catalog URL to http://updates.netbeans.org/netbeans/updates/7.0.1/uc/final/distribution/catalog.xml.gz as per the previous version of the test spec [2], it succeeds.

[1] http://wiki.netbeans.org/TS_73_APISupport_Ant_Harness
[2] http://wiki.netbeans.org/TS_71_APISupport_Ant_Harness
Comment 1 Jaroslav Tulach 2012-11-29 08:50:53 UTC
Caused by adding new element content_description to the catalog.
Comment 2 Jaroslav Tulach 2012-11-29 09:08:28 UTC
ergonomics#868fee2b97b9
Comment 3 Quality Engineering 2012-12-01 02:54:30 UTC
Integrated into 'main-golden', will be available in build *201212010001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/868fee2b97b9
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #222711: More robust with respect to unknown elements in the catalog
Comment 4 mienamoo 2012-12-04 05:53:49 UTC
Verified with build 201212030001. Thanks for the fix!


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo