Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 22230 - java.lang.NullPointerException: <no message>
java.lang.NullPointerException: <no message>
Status: CLOSED DUPLICATE of bug 21692
Product: guibuilder
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-09 12:59 UTC by Mike Kast
Modified: 2003-06-30 18:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kast 2002-04-09 12:59:36 UTC
*********** Exception occurred ************
Tue Apr 09 13:45:09 CEST 2002: 
java.lang.NullPointerException: <no message>
java.lang.NullPointerException
	at sun.reflect.NativeMethodAccessorImpl.invoke0
(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke
(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:324)
	at 
org.netbeans.modules.xml.tree.editor.TreeEditorComponent.co
mponentActivated(TreeEditorComponent.java:246)
	at 
org.openide.windows.WindowManager.activateComponent
(WindowManager.java:157)
	at 
org.netbeans.core.windows.WindowManagerImpl.activateCompone
nt(WindowManagerImpl.java:717)
	at 
org.netbeans.core.windows.frames.DefaultContainerImpl.doAct
ivateComponent(DefaultContainerImpl.java:555)
	at 
org.netbeans.core.windows.frames.DefaultContainerImpl.react
ivateSelectedComponent(DefaultContainerImpl.java:730)
	at 
org.netbeans.core.windows.frames.SplitContainerImpl.stateCh
anged(SplitContainerImpl.java:629)
	at javax.swing.JTabbedPane.fireStateChanged
(JTabbedPane.java:290)
	at 
javax.swing.JTabbedPane$ModelListener.stateChanged
(JTabbedPane.java:222)
	at 
javax.swing.DefaultSingleSelectionModel.fireStateChanged
(DefaultSingleSelectionModel.java:116)
	at 
javax.swing.DefaultSingleSelectionModel.setSelectedIndex
(DefaultSingleSelectionModel.java:50)
	at javax.swing.JTabbedPane.setSelectedIndexImpl
(JTabbedPane.java:467)
	at javax.swing.JTabbedPane.setSelectedIndex
(JTabbedPane.java:460)
	at javax.swing.JTabbedPane.insertTab
(JTabbedPane.java:572)
	at javax.swing.JTabbedPane.addTab
(JTabbedPane.java:606)
	at 
org.netbeans.core.windows.frames.SplitContainerImpl.compone
ntAdded(SplitContainerImpl.java:403)
	at 
org.netbeans.core.windows.frames.DefaultContainerImpl.addTo
pComponent(DefaultContainerImpl.java:278)
	at 
org.netbeans.core.windows.ModeImpl.addToContainer
(ModeImpl.java:1780)
	at org.netbeans.core.windows.ModeImpl.access$400
(ModeImpl.java:77)
	at 
org.netbeans.core.windows.ModeImpl$1.performCommand
(ModeImpl.java:396)
	at 
org.netbeans.core.windows.DeferredPerformer.processCommand
(DeferredPerformer.java:186)
	at 
org.netbeans.core.windows.DeferredPerformer.putRequest
(DeferredPerformer.java:83)
	at org.netbeans.core.windows.ModeImpl.dockInto
(ModeImpl.java:377)
	at org.netbeans.core.windows.ModeImpl.dockInto
(ModeImpl.java:357)
	at org.netbeans.core.windows.ModeImpl.dockInto
(ModeImpl.java:345)
	at 
org.netbeans.core.windows.WindowManagerImpl$TopComponentMan
ager.doOpen(WindowManagerImpl.java:1451)
	at 
org.netbeans.core.windows.WindowManagerImpl$TopComponentMan
ager.open(WindowManagerImpl.java:1408)
	at org.openide.windows.TopComponent.open
(TopComponent.java:212)
	at org.openide.text.CloneableEditor.open
(CloneableEditor.java:278)
	at 
org.netbeans.core.windows.layers.TCRefImpl.performCommand
(TCRefImpl.java:163)
	at 
org.netbeans.core.windows.DeferredPerformer.processCommand
(DeferredPerformer.java:186)
	at 
org.netbeans.core.windows.DeferredPerformer.putRequest
(DeferredPerformer.java:83)
	at 
org.netbeans.core.windows.layers.TCRefImpl.updateMode
(TCRefImpl.java:206)
	at 
org.netbeans.core.windows.layers.ModeData$CookiesImpl.addCo
mponents(ModeData.java:764)
	at 
org.netbeans.core.windows.layers.ModeData$CookiesImpl.updat
eComponents(ModeData.java:629)
	at 
org.netbeans.core.windows.layers.ModeData$CookiesImpl.loadD
ataSection(ModeData.java:1090)
	at 
org.netbeans.core.windows.layers.ModeData$CookiesImpl.updat
eProperties(ModeData.java:487)
	at 
org.netbeans.core.windows.layers.ModeData$CookiesImpl.updat
eAll(ModeData.java:397)
	at 
org.netbeans.core.windows.layers.ModeData$CookiesImpl.creat
eInstance(ModeData.java:341)
[catch] at 
org.netbeans.core.windows.layers.ICFolderImpl$R.run
(ICFolderImpl.java:261)
	at 
org.netbeans.core.windows.layers.ICFolderImpl.instanceCreat
e(ICFolderImpl.java:123)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.createModes(WorkspaceData.java:470)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.updateModes(WorkspaceData.java:407)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.updateAll(WorkspaceData.java:342)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.loadDataSection(WorkspaceData.java:667)
	at 
org.netbeans.core.windows.WorkspaceImpl.ensureSectionLoaded
(WorkspaceImpl.java:958)
	at 
org.netbeans.core.windows.WorkspaceImpl.setVisible
(WorkspaceImpl.java:687)
	at 
org.netbeans.core.windows.WindowManagerImpl$1.run
(WindowManagerImpl.java:431)
	at 
org.netbeans.core.windows.WindowManagerImpl.setCurrentWorks
pace(WindowManagerImpl.java:392)
	at org.netbeans.core.windows.WorkspaceImpl.activate
(WorkspaceImpl.java:463)
	at 
org.netbeans.modules.form.FormEditorSupport.activateWorkspa
ce(FormEditorSupport.java:463)
	at 
org.netbeans.modules.form.FormEditorSupport.access$200
(FormEditorSupport.java:37)
	at 
org.netbeans.modules.form.FormEditorSupport$1.run
(FormEditorSupport.java:113)
	at java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:178)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:443)
	at 
java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:190)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:144)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:130)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:98)
java.io.IOException: Instance creation failed.
	at 
org.netbeans.core.windows.layers.ICFolderImpl.instanceCreat
e(ICFolderImpl.java:131)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.createModes(WorkspaceData.java:470)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.updateModes(WorkspaceData.java:407)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.updateAll(WorkspaceData.java:342)
	at 
org.netbeans.core.windows.layers.WorkspaceData$InstanceCook
ieImpl.loadDataSection(WorkspaceData.java:667)
	at 
org.netbeans.core.windows.WorkspaceImpl.ensureSectionLoaded
(WorkspaceImpl.java:958)
	at 
org.netbeans.core.windows.WorkspaceImpl.setVisible
(WorkspaceImpl.java:687)
	at 
org.netbeans.core.windows.WindowManagerImpl$1.run
(WindowManagerImpl.java:431)
	at 
org.netbeans.core.windows.WindowManagerImpl.setCurrentWorks
pace(WindowManagerImpl.java:392)
	at org.netbeans.core.windows.WorkspaceImpl.activate
(WorkspaceImpl.java:463)
	at 
org.netbeans.modules.form.FormEditorSupport.activateWorkspa
ce(FormEditorSupport.java:463)
	at 
org.netbeans.modules.form.FormEditorSupport.access$200
(FormEditorSupport.java:37)
	at 
org.netbeans.modules.form.FormEditorSupport$1.run
(FormEditorSupport.java:113)
	at java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:178)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:443)
	at 
java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:190)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:144)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:130)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:98)
*********** Exception occurred ************
Tue Apr 09 13:45:11 CEST 2002: 
java.lang.NullPointerException: <no message>
java.lang.NullPointerException
	at 
org.netbeans.modules.form.FormDesigner.updateWholeDesigner
(FormDesigner.java:582)
	at 
org.netbeans.modules.form.FormDesigner.initialize
(FormDesigner.java:94)
	at 
org.netbeans.modules.form.FormEditorSupport.openGUI
(FormEditorSupport.java:486)
	at 
org.netbeans.modules.form.FormEditorSupport.access$400
(FormEditorSupport.java:37)
	at 
org.netbeans.modules.form.FormEditorSupport$1.run
(FormEditorSupport.java:118)
	at java.awt.event.InvocationEvent.dispatch
(InvocationEvent.java:178)
	at java.awt.EventQueue.dispatchEvent
(EventQueue.java:443)
[catch] at 
java.awt.EventDispatchThread.pumpOneEventForHierarchy
(EventDispatchThread.java:190)
	at 
java.awt.EventDispatchThread.pumpEventsForHierarchy
(EventDispatchThread.java:144)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:138)
	at java.awt.EventDispatchThread.pumpEvents
(EventDispatchThread.java:130)
	at java.awt.EventDispatchThread.run
(EventDispatchThread.java:98)
Comment 1 Jan Zajicek 2002-04-10 08:23:49 UTC
First exception is probably issue in jdk. Which version of jdk are you
using? The second one can be explained in form module.
Comment 2 Tomas Pavek 2002-04-15 13:49:36 UTC
The exception looks suspiciously similar to that from 
issue 21692. However, I still have no idea how it could 
happen...

*** This issue has been marked as a duplicate of 21692 ***
Comment 3 Quality Engineering 2003-06-30 18:21:24 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 4 Quality Engineering 2003-06-30 18:27:08 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo