Bug 221778 - Bold fonts everywhere in IDE on Ubuntu 12.10
Bold fonts everywhere in IDE on Ubuntu 12.10
Status: CLOSED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
7.3
PC Linux
: P1 with 1 vote (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
https://bugs.launchpad.net/ubuntu/+so...
jdk_bug_8012351
: RELNOTE
: 226306 227693 227895 228280 236181 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-09 02:50 UTC by akochnev
Modified: 2014-02-16 11:24 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
screenshot (35.37 KB, image/png)
2012-11-09 02:50 UTC, akochnev
Details
netbeans 7.2 with Oracle JDK 7 (65.47 KB, image/png)
2012-11-13 03:35 UTC, akochnev
Details
JDK7 running swingset3 (236.56 KB, image/png)
2012-11-13 13:43 UTC, akochnev
Details
jdk7 with gtk+ theme swingset 3 bold menu items (83.23 KB, image/png)
2012-11-14 02:58 UTC, akochnev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description akochnev 2012-11-09 02:50:15 UTC
Created attachment 127438 [details]
screenshot

The new 7.3beta (2 and 3) use bold fonts in the main menu bar, project view, etc. - see screenshot

The fonts are fine in 7.2.
Comment 1 Marian Mirilovic 2012-11-09 06:42:19 UTC
What is the JDK version you are using ? Gnome/KDE ... themes ? Please provide requested informations and reopen. Thanks in advance.
Comment 2 akochnev 2012-11-09 14:26:56 UTC
Running netbeans on jdk6. 

In ubuntu, using the default Unity desktop, which I assume is somehow based on Gnome.
Comment 3 Stanislav Aubrecht 2012-11-12 10:11:57 UTC
Please run some plain Java Swing application, e.g. SwingSet demo (in your JDK6 folder) with the same JDK, attach a screen shot and reopen, thanks.
Comment 4 akochnev 2012-11-13 03:00:38 UTC
Turns out that this is an issue w/ the IcedTea JDK that ships w/ Ubuntu by default: 

java version "1.7.0_09"
OpenJDK Runtime Environment (IcedTea7 2.3.3) (7u9-2.3.3-0ubuntu1~12.10.1)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)

Switching the JDK to JDK6 resolves the issue: 
netbeans_jdkhome="/usr/lib/jvm/java-6-sun"

It looks like the netbeans installer picked up the default JDK on the system and set it in the config file. Maybe if NetBeans doesn't look right w/ IcedTea, it should look for a JDK that it is considered compatible with. 


I'm not sure whether this is still an issue or not, if it is it's probably not an issue against NetBeans.
Comment 5 akochnev 2012-11-13 03:35:21 UTC
Created attachment 127674 [details]
netbeans 7.2 with Oracle JDK 7
Comment 6 akochnev 2012-11-13 03:37:42 UTC
The same problem manifests itself with Oracle JDK7 as the netbeans_jdkhome value:

netbeans_jdkhome="/usr/lib/jvm/java-7-oracle"

Re-opening the issue as this is a problem w/ JDK7 on both 7.2 and 7.3Beta2
Comment 7 Stanislav Aubrecht 2012-11-13 09:17:08 UTC
(In reply to comment #6)
> The same problem manifests itself with Oracle JDK7 as the netbeans_jdkhome
> value:
> 
> netbeans_jdkhome="/usr/lib/jvm/java-7-oracle"
> 
> Re-opening the issue as this is a problem w/ JDK7 on both 7.2 and 7.3Beta2

Please provide a screen shot of plain Swing app running with the same JDK and reopen, thanks.
You can use e.g. SwingSet demo app in your JDK 6 folder.
Comment 8 akochnev 2012-11-13 13:05:33 UTC
Netbeans doesn't qualify as a "plain swing app" ?
Comment 9 Stanislav Aubrecht 2012-11-13 13:09:48 UTC
(In reply to comment #8)
> Netbeans doesn't qualify as a "plain swing app" ?

If you can reproduce the problem in other Swing app then it's a bug in JDK. Otherwise it's something we can fix in NetBeans.
Comment 10 akochnev 2012-11-13 13:42:28 UTC
There is no problem w/ the menus when running Swingset3 using JDK7, see attached screenshot. 

Also, can we please stop this constant closing of the issue until it's clear that it really isn't a real issue ?
Comment 11 akochnev 2012-11-13 13:43:20 UTC
Created attachment 127721 [details]
JDK7 running swingset3

No bold menus in JDK7 Swingset3
Comment 12 Stanislav Aubrecht 2012-11-13 13:47:34 UTC
The screen shot shows the SwingSet app is running with Nimbus L&F while your NetBeans was running under GTK l&f.
Please run SwingSet2 demo app and select correct l&f in its main menu.
Comment 13 akochnev 2012-11-14 02:57:54 UTC
Indeed, an issue w/ the GTK+ theme on JDK7 - the screenshot with SwingSet3 and JDK7 and GTK+ theme makes all menu items bold. Switching to a different L&F makes the menus normal weight again. 

Not sure how to proceed from here. Stanislav - can you file the issue w/ JDK7 ?
Comment 14 akochnev 2012-11-14 02:58:26 UTC
Created attachment 127753 [details]
jdk7 with gtk+ theme swingset 3 bold menu items
Comment 15 Stanislav Aubrecht 2012-11-14 09:13:35 UTC
Please provide more info about your setup (OS version number, JDK version number etc) because I can't reproduce the problem in this setup:

Product Version: NetBeans IDE Dev (Build 20121107-35f9bf43351b)
Java: 1.7.0_07; Java HotSpot(TM) Client VM 23.3-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_07-b10
System: Linux version 3.2.0-23-generic-pae running on i386; UTF-8; en_US (nb)
Comment 16 Stanislav Aubrecht 2012-11-15 13:43:34 UTC
Waiting for the reporter to provide the requested info.
Comment 17 akochnev 2012-11-15 14:17:27 UTC
>System Info: 
  Product Version         = NetBeans IDE 7.3 Beta 2 (Build 201211062253) (#4b9ddecda013)
  Operating System        = Linux version 3.5.0-18-generic running on amd64
  Java; VM; Vendor        = 1.7.0_09; Java HotSpot(TM) 64-Bit Server VM 23.5-b02; Oracle Corporation
  Runtime                 = Java(TM) SE Runtime Environment 1.7.0_09-b05
  Java Home               = /usr/lib/jvm/java-7-oracle/jre
  System Locale; Encoding = en_US (nb); UTF-8

> uname -a
Linux bunmonster 3.5.0-18-generic #29-Ubuntu SMP Fri Oct 19 10:26:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

This is an Ubuntu 12.10 running under the default Unity desktop

What other info is needed ?
Comment 18 Stanislav Aubrecht 2012-11-15 14:57:07 UTC
It seems to be a bug in Ubuntu: https://bugs.launchpad.net/ubuntu/+source/openjdk-7/+bug/937200
Comment 19 seltzlab 2012-11-16 17:56:26 UTC
The solution (worked for me too)

sudo apt-get remove fonts-unfonts-core
Comment 20 Marian Mirilovic 2013-02-19 18:47:59 UTC
*** Bug 226306 has been marked as a duplicate of this bug. ***
Comment 21 tomzi 2013-02-23 17:18:41 UTC
(In reply to comment #19)
> The solution (worked for me too)
> 
> sudo apt-get remove fonts-unfonts-core

From https://bugs.launchpad.net/ubuntu/+source/openjdk-7/+bug/937200 it says that only when you install wine on ubuntu fonts-unfonts-core is being installed, which messes up the fonts for java.

Uninstalling them should work
Comment 22 tomzi 2013-02-27 09:48:18 UTC
I wonder - if the resolution 'WORKSFORME' is correct since it definately IS an issue.

It might be fixable on netbeans side by correcting somehow the 'bold'ness or even to make sure not to use the default fonts?

I wonder if anybody is listening as long this bug stays in 'WORKSFORME'?
Comment 23 Marian Mirilovic 2013-02-27 12:37:42 UTC
(In reply to comment #22)
> I wonder - if the resolution 'WORKSFORME' is correct since it definately IS an
> issue.

You are right, the correct resolution is WOTNFIX

 
> It might be fixable on netbeans side by correcting somehow the 'bold'ness or
> even to make sure not to use the default fonts?

No, that is a wrong way to go.
Comment 24 tomzi 2013-02-28 12:35:55 UTC
Sorry to bother you more, but may I ask then, what the right way to do this is?
Comment 25 tomzi 2013-03-01 10:13:02 UTC
What about a Info page that is shown on startup of netbeans for those, who have 'fonts-unfonts-core' installed, showing how to resolve the issue:

sudo apt-get remove fonts-unfonts-core
Comment 26 Stanislav Aubrecht 2013-03-01 10:28:57 UTC
(In reply to comment #25)
> What about a Info page that is shown on startup of netbeans for those, who have
> 'fonts-unfonts-core' installed, showing how to resolve the issue:
> 
I don't think we can detect that from Java...
Comment 27 luislobo 2013-03-14 13:34:59 UTC
I had the same issue, with Linux Mint.

sudo apt-get remove fonts-unfonts-core worked for me.

Distributor ID: LinuxMint
Description:    Linux Mint 14 Nadia
Release:        14
Codename:       nadia
Comment 28 Marian Mirilovic 2013-03-20 13:35:56 UTC
*** Bug 227693 has been marked as a duplicate of this bug. ***
Comment 29 Marian Mirilovic 2013-03-25 15:38:02 UTC
*** Bug 227895 has been marked as a duplicate of this bug. ***
Comment 30 tomzi 2013-03-26 10:28:04 UTC
Is there really no way that you can do sth on the 'netbeans' side to not show bold fonts - like 
- Using another font? 
- Warning the user on startup
- Giving the user information on how to workaround this 'boldness'

Can you guys do sth actively to see that the original bug gets fixed?

Who's error is it anyway that netbeans gets the bold font although it's not supposed to be there?
Comment 31 Antonin Nebuzelsky 2013-03-29 17:47:38 UTC
Standa, can you file a bug againt JDK and put a reference here? Thanks.
Comment 32 Antonin Nebuzelsky 2013-04-16 13:08:29 UTC
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8012351
Comment 33 Vladimir Riha 2013-04-19 12:17:16 UTC
*** Bug 228280 has been marked as a duplicate of this bug. ***
Comment 34 JScoobyCed 2013-06-25 08:45:42 UTC
I would like to add some info to the mentioned JDK1.7 bug but I don't know how to contact the bug page on sun website.
This issue raised for me with 7.3 only after I installed wine-1.4. After digging, I found that wine installs the package
unfont-core
which creates the fonts:
UnBatangBold.ttf
UnBatang.ttf
UnDinaruBold.ttf
UnDinaruLight.ttf
UnDinaru.ttf
UnDotumBold.ttf
UnDotum.ttf
UnGraphicBold.ttf
UnGraphic.ttf
UnGungseo.ttf
UnPilgiBold.ttf
UnPilgi.ttf

in /usr/share/fonts/truetype/unfonts-core/ folder

After removing this folder Netbeans 7.3 fonts are back to normal (needs restart of NB7.3)

Is there a way to pass this info to the guys at http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=8012351?
Comment 35 Ondrej Brejla 2013-09-28 07:48:07 UTC
*** Bug 236181 has been marked as a duplicate of this bug. ***
Comment 36 Jackie_Rosen 2014-02-16 11:24:41 UTC
SPAM - Removed by Administrator


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo