Bug 22171 - "Callee" and "called" still refer to up and down
"Callee" and "called" still refer to up and down
Status: CLOSED WONTFIX
Product: debugger
Classification: Unclassified
Component: Code
3.x
PC Windows ME/2000
: P3 (vote)
: 3.x
Assigned To: Maya Venkatraman
issues@ide
: UI
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-07 20:41 UTC by eadams
Modified: 2003-06-30 17:28 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eadams 2002-04-07 20:41:27 UTC
When the actions to move to the callee and called methods
were added there was a lively debate about naming them.
We carefully stayed away from the words Up and Down as
people conceive the the call stack with different orientations.
Hence the actions are named "Go to Calling method" and 
"Go to Called Method".  This is good.  

The problem is that both the keyboard accelerators and the
buttons still refer to Up and Down.  The keyboard accelerators
are Ctrl-Alt+Up and Down and the toolbar buttons differ only
with an up and down arrow.
Comment 1 Jan Jancura 2002-04-08 12:54:47 UTC
UI team is responsilbe for icons&shortcuts.
Comment 2 Jiri Mzourek 2002-04-09 12:46:03 UTC
Moving to Maya.
Comment 3 Jiri Mzourek 2002-05-31 14:30:09 UTC
Yes, we are responsible, but this issue should be tracked in debugger.
Thanks.
Comment 4 David-john Burrowes 2002-06-03 22:31:26 UTC
We spent a bunch of time trying to find some way to avoid "up" and "down" indications in the icons, 
and really couldn't think of anything to do about this.  We could possibly change the shortcut keys 
to something else, but I'm not sure that this is a problem which is especially important.  The keys 
match the default arrangement of the stack, and so they are actually quite appropriate for most 
users.  Changing them will make them non-appropriate for all users.
I'd actually like to close this issue.
Comment 5 eadams 2002-06-03 22:40:21 UTC
Agreed.  I haven't been able to come up with an suitable
alternatives either.  I'm closing as WONTFIX.

Comment 6 Quality Engineering 2003-06-30 17:24:44 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.
Comment 7 Quality Engineering 2003-06-30 17:28:27 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo