Bug 221400 - Deadlock with blocking of whole X session
Deadlock with blocking of whole X session
Status: RESOLVED DUPLICATE of bug 213926
Product: apisupport
Classification: Unclassified
Component: Project
7.3
PC Linux
: P2 (vote)
: 7.3
Assigned To: issues@apisupport
issues@apisupport
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-03 09:08 UTC by everflux
Modified: 2012-11-04 22:51 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Thread dump of netbeans deadlock (29.39 KB, application/octet-stream)
2012-11-03 09:09 UTC, everflux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description everflux 2012-11-03 09:08:50 UTC
[ BUILD # : 201211020750 ]
[ JDK VERSION : 1.7.9 ]

When testing the Netbeans 7.3 beta 2 build my X session was blocked and
Netbeans stopped working.

Happened when Netbeans was just started and I clicked on the menu in order to
obtain the build number.
I was able to obtain a threaddump from the console with the jcmd cli tool - I
am not sure if this could be a JDK problem instead of Netbeans/RCP. (The locks
seem to be owned by AWT threads?)
Comment 1 everflux 2012-11-03 09:09:15 UTC
Created attachment 127055 [details]
Thread dump of netbeans deadlock
Comment 2 everflux 2012-11-03 09:09:46 UTC
I had to kill the JVM with -9 from the console in order to be able to use my X session again. This was really frightening.
Comment 3 Antonin Nebuzelsky 2012-11-04 22:51:49 UTC
Please switch to promoted builds of 7u10, where this JDK bug is fixed, available at
http://jdk7.java.net/download.html

*** This bug has been marked as a duplicate of bug 213926 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo