Bug 221357 - OutOfMemoryError after Building projects
OutOfMemoryError after Building projects
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
7.3
PC Windows 7
: P2 (vote)
: 7.3
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks: 221359
  Show dependency treegraph
 
Reported: 2012-11-02 14:20 UTC by stefan79
Modified: 2012-11-20 22:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log-File. (205.85 KB, text/plain)
2012-11-02 14:21 UTC, stefan79
Details
Compiler-Output (25.40 KB, image/png)
2012-11-02 14:21 UTC, stefan79
Details
Log-File. (297.37 KB, application/octet-stream)
2012-11-12 15:02 UTC, stefan79
Details
Log-File after restarting (OOME occured again) (66.44 KB, application/octet-stream)
2012-11-13 09:36 UTC, stefan79
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefan79 2012-11-02 14:20:42 UTC
[ BUILD # : 201211020001 ]
[ JDK VERSION : 1.7.7 ]

Today I pressed at the "Build Project" - button.
After about 15 minutes, this ends in an OutOfMemoryError and the IDE was
unresponsable.
I tried to make Thread - Dump, but jvisualvm doesn´t shows the IDE.


Compiler-Log is showing that the copy-Action has finished.
Comment 1 stefan79 2012-11-02 14:21:01 UTC
Created attachment 127020 [details]
Log-File.
Comment 2 stefan79 2012-11-02 14:21:32 UTC
Created attachment 127021 [details]
Compiler-Output
Comment 3 stefan79 2012-11-02 14:52:59 UTC
Dump was uploaded to hudson.
-> http://deadlock.netbeans.org/hudson/job/upload/86/
Comment 4 Tomas Hurka 2012-11-05 10:37:23 UTC
It looks like checking for LowMemory does not work well.
Comment 5 Tomas Hurka 2012-11-05 10:38:17 UTC
Heap dump available on request.
Comment 6 Tomas Zezula 2012-11-05 15:37:27 UTC
Added logging jet-main 406bbad27b82.
Seems a problem with MemoryMXBean.
Please can you run the IDE with -J-Dorg.netbeans.modules.parsing.lucene.support.LowMemoryWatcher.level=FINEST option and retry to reproduce the problem?
You will need a build containing the changeset 406bbad27b82.
Thanks!
Comment 7 Quality Engineering 2012-11-06 03:11:08 UTC
Integrated into 'main-golden', will be available in build *201211060001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/406bbad27b82
User: Tomas Zezula <tzezula@netbeans.org>
Log: #221357:OutOfMemoryError after Building projects
Comment 8 Tomas Zezula 2012-11-06 18:57:32 UTC
Please attach the log with the -J-Dorg.netbeans.modules.parsing.lucene.support.LowMemoryWatcher.level=FINEST and reopen then.
Comment 9 stefan79 2012-11-12 15:02:26 UTC
Created attachment 127637 [details]
Log-File.

OutOfMemoryError occured again at current build (201211120001).
LowMemoryWatcher was activated.

I´ll upload the Dump to hudson.
Comment 10 stefan79 2012-11-12 15:22:39 UTC
Dump is available at hudson:
http://deadlock.netbeans.org/hudson/job/upload/99/
Comment 11 Tomas Zezula 2012-11-12 18:34:52 UTC
Seems very strange as right before OOM there were nearly 300MB of free space:
 Max memory: 1.908.932.608, Used memory: 1.617.979.552,
Comment 12 stefan79 2012-11-13 09:36:22 UTC
Created attachment 127686 [details]
Log-File after restarting (OOME occured again)

Yesterday this was the same story:
-) I refreshed some source files (update CVS)
-) NB started Background-Scanning -> OOME occured
-) I restarted NB -> OOME occured again
-) I restarted NB -> OOME occured again
-) I cleared the Cache-Directory and startet NetBeans again -> It works
Comment 13 Jan Lahoda 2012-11-14 13:06:05 UTC
Tomas, you are looking into this, right?
Comment 14 Tomas Zezula 2012-11-20 22:11:28 UTC
Restored the behaviour of LowMemoryWatch not to cross the CMS stop the world limit.
jet-main fdbf73f77a1d


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo