Bug 221267 - NullPointerException at org.netbeans.modules.profiler.stp.SelectProfilingTask.selectAttachProfilerTask
NullPointerException at org.netbeans.modules.profiler.stp.SelectProfilingTask...
Status: RESOLVED FIXED
Product: profiler
Classification: Unclassified
Component: Base
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Jiri Sedlacek
issues@profiler
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 15:44 UTC by lehel
Modified: 2012-11-06 03:11 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.99 KB, text/plain)
2012-11-01 15:44 UTC, lehel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lehel 2012-11-01 15:44:45 UTC
Build: NetBeans IDE Dev (Build 201211010001)
VM: Java HotSpot(TM) Client VM, 23.5-b02, Java(TM) SE Runtime Environment, 1.7.0_09-b05
OS: Windows XP

User Comments:
lehel: NetBeans ide should contain Profile menu, Tools -> Options dialog should contain Profiler tab in Miscellaneous section. But it did not contain. 
This error appeared running the Profile from toolbar.




Stacktrace: 
java.lang.NullPointerException
   at org.netbeans.modules.profiler.stp.SelectProfilingTask.selectAttachProfilerTask(SelectProfilingTask.java:333)
   at org.netbeans.modules.profiler.stp.SelectProfilingTask$ConfiguratorProvider.configureAttachProfilerTask(SelectProfilingTask.java:167)
   at org.netbeans.modules.profiler.api.TaskConfigurator.configureAttachProfilerTask(TaskConfigurator.java:114)
   at org.netbeans.modules.profiler.actions.ProfilingSupport.selectTaskForAttach(ProfilingSupport.java:165)
   at org.netbeans.modules.profiler.actions.ProfilingSupport$1.run(ProfilingSupport.java:245)
   at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1454)
Comment 1 lehel 2012-11-01 15:44:47 UTC
Created attachment 126925 [details]
stacktrace
Comment 2 Jiri Sedlacek 2012-11-05 14:32:00 UTC
Profiler options are in Options | Java | Profiler. If you can't see the Profile menu, your IDE is probably incorrectly installed - make sure you're running with a clean user&cache directory.

The exception was thrown from Attach Profiler action, not Profile action as mentioned. I assume you've invoked Profile or Attach Profiler before. Works fine on my side, not reproducible. Please provide detailed steps if you happen to get the exception again.

Implemented a workaround to prevent the NPE, can't do more without a reproducible test case: http://hg.netbeans.org/profiler-main/rev/da76d8aa2fa7
Comment 3 Quality Engineering 2012-11-06 03:11:21 UTC
Integrated into 'main-golden', will be available in build *201211060001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/da76d8aa2fa7
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #221267 - prevent the NPE probably caused by incorrect synchronization of SPT.cleanup(), not reproducible


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo