Bug 220394 - CodeCompletion took 3500 ms.
CodeCompletion took 3500 ms.
Status: RESOLVED WONTFIX
Product: java
Classification: Unclassified
Component: Compiler
7.3
All All
: P3 (vote)
: 7.3
Assigned To: Dusan Balek
issues@java
EXCEPTIONS_REPORT perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 03:53 UTC by trekxander
Modified: 2012-10-19 08:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (92.47 KB, application/nps)
2012-10-19 03:53 UTC, trekxander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description trekxander 2012-10-19 03:53:49 UTC
This bug was originally marked as duplicate of bug 174776, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.3 Beta (Build 201210011125)
VM: Java HotSpot(TM) Client VM, 23.3-b01, Java(TM) SE Runtime Environment, 1.7.0_07-b10
OS: Windows Vista

User Comments:
trekxander: invoking code completion



Maximum slowness yet reported was 3500 ms, average is 3500
Comment 1 trekxander 2012-10-19 03:53:52 UTC
Created attachment 126168 [details]
nps snapshot
Comment 2 Dusan Balek 2012-10-19 08:42:24 UTC
Time spent in the 'enter' and 'analyze' phases of the javac compilation. 'Please wait' should be displayed in code completion meanwhile. Closing as wontfix.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo