Bug 220239 - I am getting error , Unknow Option -mixed
I am getting error , Unknow Option -mixed
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Selenium
7.2
PC Windows XP
: P1 (vote)
: 7.3
Assigned To: Martin Fousek
issues@contrib
:
: 217456 220081 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 07:02 UTC by manoj18k
Modified: 2013-01-31 12:35 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (55.98 KB, text/plain)
2012-10-17 07:02 UTC, manoj18k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manoj18k 2012-10-17 07:02:11 UTC
Product Version = NetBeans IDE 7.2 (Build 201207171143)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.7.0_07
Runtime = Java HotSpot(TM) Client VM 23.3-b01


Hi

I have the existing selenium scripts in which are written in java, these were running successfully on Netbeans 7.1.2 , but when i tried running these scripts on Netbeans 7.2 , it says that :



Unknown option: -mixed
Usage: <main class> [options]
 The XML suite files to run
  Options:
    -configfailurepolicy               Configuration failure policy (skip or
                                       continue)
    -d                                 Output directory
    -dataproviderthreadcount           Number of threads to use when running
                                       data providers
    -excludegroups                     Comma-separated list of group names to 
                                       exclude
    -groups                            Comma-separated list of group names to be
                                       run
    -junit                             JUnit mode
                                       Default: false
    -listener                          List of .class files or list of class
                                       names implementing ITestListener or
                                       ISuiteListener
    -methods                           Comma separated of test methods
                                       Default: []
    -methodselectors                   List of .class files or list of class
                                       names implementing IMethodSelector
    -objectfactory                     List of .class files or list of class
                                       names implementing ITestRunnerFactory
    -parallel                          Parallel mode (methods, tests or classes)
    -port                              The port
    -reporter                          Extended configuration for custom report
                                       listener
    -suitename                         Default name of test suite, if not
                                       specified in suite definition file or
                                       source code
    -suitethreadpoolsize               Size of the thread pool to use to run
                                       suites
                                       Default: 1
    -testclass                         The list of test classes
    -testjar                           A jar file containing the tests
    -testname                          Default name of test, if not specified in
                                       suitedefinition file or source code
    -testnames                         The list of test names to run
    -testrunfactory, -testRunFactory   The factory used to create tests
    -threadcount                       Number of threads to use when running
                                       tests in parallel
    -usedefaultlisteners               Whether to use the default listeners
                                       Default: true
    -log, -verbose                     Level of verbosity

Java Result: 1



Please let me know what is the issue in it.
Thanks
Comment 1 manoj18k 2012-10-17 07:02:18 UTC
Created attachment 126049 [details]
IDE log
Comment 2 Martin Fousek 2012-10-23 07:51:41 UTC
Are you able to attach your scripts? I'm afraid that between 7.1.2 and 7.2 didn't change much things in the Selenium modules ... where did the "-mixed" option come from, don't you know? Could you take a look on it?
Comment 3 Theofanis Oikonomou 2012-12-20 12:53:43 UTC
*** Bug 217456 has been marked as a duplicate of this bug. ***
Comment 4 Martin Fousek 2013-01-02 07:07:14 UTC
Marking as incomplete for now. Reporters please ,could you provide more information to this issue and reopen the issue again? Thanks a lot...
Comment 5 sf019jp 2013-01-07 04:52:14 UTC
Hi,

When in NetBeans 7.2x to run the junit,
Changed reading order for class loading "junit library"
and other "jar library" ?

<detail>
I have encountered the same symptoms too.
I have created a "selenium-2.25.0" library in NetBeans.
Which includes the following:
-----
selenium-java-2.25.0.jar
libs/apache-mime4j-0.6.jar
libs/bsh-1.3.0.jar
libs/cglib-nodep-2.1_3.jar
libs/commons-codec-1.6.jar
libs/commons-collections-3.2.1.jar
libs/commons-exec-1.1.jar
libs/commons-io-2.0.1.jar
libs/commons-jxpath-1.3.jar
libs/commons-lang-2.6.jar
libs/commons-logging-1.1.1.jar
libs/cssparser-0.9.5.jar
libs/guava-12.0.jar
libs/hamcrest-core-1.1.jar
libs/hamcrest-library-1.1.jar
libs/htmlunit-2.9.jar
libs/htmlunit-core-js-2.9.jar
libs/httpclient-4.1.3.jar
libs/httpcore-4.1.3.jar
libs/httpmime-4.1.3.jar
libs/ini4j-0.5.2.jar
libs/jcommander-1.13.jar
libs/jna-3.4.0.jar
libs/jna-platform-3.4.0.jar
libs/json-20080701.jar
libs/junit-dep-4.10.jar
libs/nekohtml-1.9.15.jar
libs/netty-3.2.7.Final.jar
libs/operadriver-0.14.jar
libs/protobuf-java-2.4.1.jar
libs/sac-1.3.jar
libs/serializer-2.7.1.jar
libs/testng-6.0.1-nobsh-noguice.jar
libs/webbit-0.4.8-SNAPSHOT.jar
libs/xalan-2.7.1.jar
libs/xercesImpl-2.9.1.jar
libs/xml-apis-1.3.04.jar
-----

I have created a simple project.
Only default Java source, Test Source, and include
library selenium-2.25.0

When use NetBeans 7.1, JUnit Test is normal end.
But, use NetBeans 7.2/7.2.1, Get message "Unknown option: -mixed..."

When I delete the files libs/* in selenium-2.25.0,
use NetBeans 7.2/7.2.1 is normal end.

But, it can not be implemented properly is only
selenium-java-2.25.0.jar.

Do not return to a previous order class loading?
Comment 6 Martin Fousek 2013-01-28 15:52:15 UTC
I was able to reproduce it now. Not sure what could be wrong there. Anyway another class loading is not easily possible since it is handled as common library. Right now, I'm working on the Selenium upgrade to 2.28.0 which will be available for NB7.3 and it works well to me there.
Comment 7 Martin Fousek 2013-01-29 07:49:18 UTC
*** Bug 220081 has been marked as a duplicate of this bug. ***
Comment 8 Martin Fousek 2013-01-31 12:35:33 UTC
This should be fixed in plugins available for the NetBeans73. Feel free to test it out in the NetBeans 7.3RC with these plugins:
http://plugins.netbeans.org/plugin/37739/?show=true
http://plugins.netbeans.org/plugin/46611/?show=true
http://plugins.netbeans.org/plugin/37732/?show=true
http://plugins.netbeans.org/plugin/46567/?show=true

BTW, newly it's required to have installed libraries for the Ant Project and Server plugins. I believe this will resolve your troubles. Thanks for reporting.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo