Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 219904 - Find Usages does not separate results by file
Find Usages does not separate results by file
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Refactoring
7.3
All All
: P3 (vote)
: 8.0
Assigned To: Ondrej Brejla
issues@php
:
: 224061 224926 226265 226539 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 11:14 UTC by Vladimir Riha
Modified: 2013-02-25 09:26 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
screenshot (sorry for GTK...) (244.63 KB, image/png)
2012-10-11 11:14 UTC, Vladimir Riha
Details
patch (20.41 KB, patch)
2012-10-11 13:54 UTC, Ondrej Brejla
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Riha 2012-10-11 11:14:14 UTC
Created attachment 125766 [details]
screenshot (sorry for GTK...)

I don't know if this is intended, but 
- if you try Find Usage in PHP bundle, the results are not separated by file so you cannot tell which usage is where and it is pretty uncomfortable. 
- The same happens with ALL bundle where ONLY PHP is activated
- Once I activate Java SE, the results are again separated by file.


Product Version: NetBeans IDE Dev (Build 201210110002)
Java: 1.7.0_10-ea; Java HotSpot(TM) Client VM 23.6-b03
System: Linux version 3.2.0-31-generic-pae running on i386; UTF-8; en_US (nb)
Comment 1 Ondrej Brejla 2012-10-11 12:02:04 UTC
Interesting :) Really don't know what affects that...
Comment 2 Ondrej Brejla 2012-10-11 12:22:27 UTC
It behaves somehow strangely...if I deactivate J2SE then it works still properly...under the file node...
Comment 3 Ondrej Brejla 2012-10-11 12:42:39 UTC
Lado can you test it in 7.2? Or in some earlier version? I think that it will work in the same way.
Comment 4 Vladimir Riha 2012-10-11 12:50:18 UTC
I tried PHP bundle of 7.2 and it works fine here
Comment 5 Ondrej Brejla 2012-10-11 12:53:15 UTC
7.2 PHP bundle? With clean user dir? It's strange...afaik we did nothing in refactoring modules...
Comment 6 Ondrej Brejla 2012-10-11 12:54:38 UTC
Ralph, what do you think? What can we do to fix it? I don't have a clue...
Comment 7 Vladimir Riha 2012-10-11 12:56:37 UTC
yep, clean user dir. I noticed this about a week or two back and I thought it is some "nice" improvement :) But I don't use it that often so it might be older...
Comment 8 Ondrej Brejla 2012-10-11 13:25:32 UTC
Hmm...I got it. Probably it needs a whole new implementation of TreeElementFactoryImplementation and something like FileTreeElement. I think that its more likely enhancement, because many new classes will have to be implemented :/ I think that it's a side effect taht it works now... Nice but side effect :)

So what do you mean? I can implement it, but not sure if it will be safe.
Comment 9 Vladimir Riha 2012-10-11 13:35:52 UTC
Indeed a nice side effect :) I'm fine with turning it into enhancement(and thus not targetting it to 7.3, right)?
Comment 10 Ondrej Brejla 2012-10-11 13:54:11 UTC
Created attachment 125779 [details]
patch

Ok, so here is the patch and I'll integrate it as an enhancement for next release.
Comment 11 Ondrej Brejla 2012-12-17 14:01:12 UTC
Fixed in web-main #7d680889832f

(it's on branch for php 7.4 features ;)
Comment 12 Ondrej Brejla 2012-12-20 08:52:37 UTC
*** Bug 224061 has been marked as a duplicate of this bug. ***
Comment 13 Ondrej Brejla 2013-01-16 10:53:58 UTC
*** Bug 224926 has been marked as a duplicate of this bug. ***
Comment 14 Quality Engineering 2013-01-30 03:40:54 UTC
Integrated into 'main-golden', will be available in build *201301300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7d680889832f
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #219904 - Find Usages does not separate results by file
Comment 15 Vladimir Riha 2013-02-07 13:14:39 UTC
Thanks, verified with PHP bundle


Product Version: NetBeans IDE Dev (Build 201302070001)
Java: 1.7.0_13; Java HotSpot(TM) Client VM 23.7-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_13-b20
System: Linux version 3.2.0-35-generic-pae running on i386; UTF-8; en_US (nb)
Comment 16 Ondrej Brejla 2013-02-18 10:38:29 UTC
*** Bug 226265 has been marked as a duplicate of this bug. ***
Comment 17 Ondrej Brejla 2013-02-25 09:26:45 UTC
*** Bug 226539 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo