Bug 21960 - Tomcat 4.0 Server module has ModuleInstall performance degradation
Tomcat 4.0 Server module has ModuleInstall performance degradation
Status: RESOLVED WONTFIX
Product: serverplugins
Classification: Unclassified
Component: Tomcat
-FFJ-
Sun Solaris
: P1 (vote)
: -FFJ-
Assigned To: Damian Frach
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-29 04:15 UTC by fomenko
Modified: 2002-03-29 17:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fomenko 2002-03-29 04:15:59 UTC
Module org.netbeans.modules.web.tomcat.tomcat40/1  ModuleInstall time in the
second IDE start in the FFJ build 020327 took 111 ms vs 28 ms in the FFJ build
020307.
Comment 1 _ rkubacki 2002-03-29 07:22:45 UTC
The reason is that we need to copy part of tomcat instalation into
userdir because in general user should not access any file in IDE
instalation.

The question is whether this can be done lazily (other modules can
built on top of our stuff). Also this performance regression affects
only first start. Next opening doesn't perform such huge operation.
Comment 2 _ rkubacki 2002-03-29 07:24:18 UTC
Tomcat 4 plugin is not part of NetBeans yet.
Comment 3 Damian Frach 2002-03-29 16:36:56 UTC
this problem was caused by fixing 4621234.
and we expected performance regression.

the second and other starts of IDE should be faster then 
first, but will be longer then 28 ms. I did today some 
other performance improvements for second and other 
restarts.

I discussed the solution with Jasse, but this fix is only 
possible. Jasse uses similiar technik, when he copies 
sample-dir application into the user-home during first 
start. But he does it during sample-dir FS mounting, so you 
can not measure it as his module startup time. But it is 
part of startup time, because FSs are mounted during start 
up.

So I do not see any possibility, how to reduce this 
performance regression.

So, I think, this bug should be closed as "will not fix".

If you do not agree, reopen please this bug and add your 
comments.
Comment 4 Damian Frach 2002-03-29 17:31:43 UTC
I measured method "restored" in TomcatModuleInstall object.
I got these data:

- fresh IDE
1.start 625 ms
2.start 156 ms
3.start 109 ms
4.start 110 ms
- again fresh IDE
1.start 672 ms
2.start 110 ms
3.start 94 ms
4.start 110 ms

So second and other starts should be about 5-6 times faster 
then first.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo