Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 219518 - unmappable character for encoding UTF-8
unmappable character for encoding UTF-8
Status: RESOLVED DUPLICATE of bug 216526
Product: webservices
Classification: Unclassified
Component: JAX-WS
7.2
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Denis Anisimov
issues@webservices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-04 12:08 UTC by catjav
Modified: 2012-10-05 08:14 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
IDE log (61.21 KB, text/plain)
2012-10-04 12:08 UTC, catjav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description catjav 2012-10-04 12:08:09 UTC
Product Version = NetBeans IDE 7.2 (Build 201207171143)
Operating System = Windows XP version 5.1 running on x86
Java; VM; Vendor = 1.6.0_30
Runtime = Java HotSpot(TM) Client VM 20.5-b03


I try to add a web service client from a local wsdl to a project test. The clean and build send the following message : "unmappable character for encoding UTF-8". If i open this project in netbeans 7.1 , without modifying anything, the compile is ok. I have the same problem with 5 wsdl.The same wsdl added to a new project created with netbeans 7.0.1 can be compile whith NB7.2.

Thanks.
Comment 1 catjav 2012-10-04 12:08:14 UTC
Created attachment 125379 [details]
IDE log
Comment 2 Denis Anisimov 2012-10-04 12:48:52 UTC
It looks like duplicate of the issue #216526 and #208735.
Recent JAXB version generates source code using system default encoding.
NB uses its own encoding options for editor and javac. Issue appears where 
system encoding differs from NB encoding.


Please provide your system encoding .
As I understand your project encoding setting is UTF-8. Is it correct ?
Comment 3 catjav 2012-10-04 14:39:50 UTC
My project is in UTF-8.
My system encoding ??? In System.getProperties, I see 'file.encoding', value : 'UTF-8'. Is it what you ask ?
Comment 4 Denis Anisimov 2012-10-04 14:44:46 UTC
Thank you for your answer.
(In reply to comment #3)
> My project is in UTF-8.
> My system encoding ??? In System.getProperties, I see 'file.encoding', value :
> 'UTF-8'. Is it what you ask ?
No. Please open Menu : Help->About. There is a text area with required NB environment information.
F.e. there is a "System:" field .
In my case it is "Windows 7 version 6.1 running on amd64; Cp1251; en_US (nb)".
What is yours ?
Comment 5 catjav 2012-10-04 14:54:17 UTC
Here is my info : System: Windows XP version 5.1 running on x86; Cp1252; fr_BE (nb)
Comment 6 Denis Anisimov 2012-10-04 14:58:00 UTC
(In reply to comment #5)
> Here is my info : System: Windows XP version 5.1 running on x86; Cp1252; fr_BE
> (nb)

It means it is really the duplicate of the issue issue #216526 .

The workaround is : open your project settings and change Encoding option 
( Sources category ) from UTF-8 to windows-1252 or ISO-8859-1.

*** This bug has been marked as a duplicate of bug 216526 ***
Comment 7 catjav 2012-10-05 07:58:25 UTC
Ok for the workaround.But we must use UTF8 for our projects.
So, have you an idea if the integration of JAXB will be adapted in the next version of Netbeans  ?
Comment 8 Denis Anisimov 2012-10-05 08:14:37 UTC
(In reply to comment #7)
> Ok for the workaround.But we must use UTF8 for our projects.
> So, have you an idea if the integration of JAXB will be adapted in the next
> version of Netbeans  ?

You may use encoding setting for NB at the start time. Find 
etc/netbeans.conf file in your NB distribution and add 
-J-Dfile.encoding=UTF8
to the netbeans_default_options.
As a result overall NB JVM will be using UTF8 as a system encoding. 
This encoding will be used by JAX-WS ant tasks ( and JAXB impl ) as a consequence.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo