Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 219305 - NullPointerException at javax.swing.text.FlowView$LogicalView.getPreferredSpan
NullPointerException at javax.swing.text.FlowView$LogicalView.getPreferredSpan
Status: RESOLVED INCOMPLETE
Product: platform
Classification: Unclassified
Component: Help System
7.2
All All
: P3 (vote)
: TBD
Assigned To: Jaroslav Havlin
issues@platform
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-02 06:47 UTC by rr151
Modified: 2012-10-10 08:27 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.95 KB, text/plain)
2012-10-02 06:47 UTC, rr151
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rr151 2012-10-02 06:47:44 UTC
Build: NetBeans IDE 7.2 (Build 201207171143)
VM: Java HotSpot(TM) Client VM, 14.2-b01, Java(TM) SE Runtime Environment, 1.6.0_16-b01
OS: Windows Vista

Stacktrace: 
java.lang.NullPointerException
   at javax.swing.text.FlowView$LogicalView.getPreferredSpan(FlowView.java:715)
   at javax.swing.text.FlowView.calculateMinorAxisRequirements(FlowView.java:216)
   at javax.swing.text.html.ParagraphView.calculateMinorAxisRequirements(ParagraphView.java:128)
   at javax.swing.text.BoxView.checkRequests(BoxView.java:918)
   at javax.swing.text.BoxView.getMinimumSpan(BoxView.java:551)
   at javax.swing.text.html.ParagraphView.getMinimumSpan(ParagraphView.java:261)
Comment 1 rr151 2012-10-02 06:47:47 UTC
Created attachment 125187 [details]
stacktrace
Comment 2 Jaroslav Havlin 2012-10-05 11:38:34 UTC
Please, can you reproduce this bug, or has it happened only once?
Comment 3 Jaroslav Havlin 2012-10-09 15:53:22 UTC
The error may be caused by content of the help page. Which help were you going to show? Thanks.
Comment 4 rr151 2012-10-09 18:28:06 UTC
(In reply to comment #2)
> Please, can you reproduce this bug, or has it happened only once?

It has not happend again since restarting the program.
Comment 5 rr151 2012-10-09 18:30:56 UTC
(In reply to comment #3)
> The error may be caused by content of the help page. Which help were you going
> to show? Thanks.

I can't remember what help topic(s) I was looking at when the error occurred.
Comment 6 Jaroslav Havlin 2012-10-10 08:27:27 UTC
> > Please, can you reproduce this bug, or has it happened only once?
> 
> It has not happend again since restarting the program.

> > The error may be caused by content of the help page. Which help were you
> > going to show? Thanks.
> 
> I can't remember what help topic(s) I was looking at when the error occurred.

I cannot reproduce it too. It seems to be a random Swing bug.
Closing for now. Please reopen when it happen again and we get some more information about it.
Thank you very much.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo