Bug 219089 - [73cat] java.lang.ClassCastException: org.netbeans.modules.refactoring.api.RenameRefactoring cannot be cast to org.netbeans.modules.refactoring.api.MoveRefactoring
[73cat] java.lang.ClassCastException: org.netbeans.modules.refactoring.api.Re...
Status: RESOLVED DUPLICATE of bug 218766
Product: java
Classification: Unclassified
Component: Refactoring
7.3
PC Linux
: P3 (vote)
: 7.3
Assigned To: Ralph Ruijs
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-26 21:10 UTC by mstarnacki
Modified: 2012-11-23 23:01 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Log file (70.66 KB, application/octet-stream)
2012-09-26 21:10 UTC, mstarnacki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mstarnacki 2012-09-26 21:10:31 UTC
Created attachment 124975 [details]
Log file

I tried to rename package name in Java Project.
Comment 1 Tomas Pavek 2012-11-23 14:28:11 UTC
Exception in the log:

SEVERE [org.openide.util.Exceptions]
java.lang.ClassCastException: org.netbeans.modules.refactoring.api.RenameRefactoring cannot be cast to org.netbeans.modules.refactoring.api.MoveRefactoring
	at org.netbeans.modules.refactoring.java.plugins.MoveFileRefactoringPlugin.getRelevantFiles(MoveFileRefactoringPlugin.java:476)
	at org.netbeans.modules.refactoring.java.plugins.MoveFileRefactoringPlugin.prepare(MoveFileRefactoringPlugin.java:553)
[catch] at org.netbeans.modules.refactoring.api.AbstractRefactoring.pluginsPrepare2(AbstractRefactoring.java:437)
	at org.netbeans.modules.refactoring.api.AbstractRefactoring.pluginsPrepare(AbstractRefactoring.java:421)
	at org.netbeans.modules.refactoring.api.AbstractRefactoring.prepare(AbstractRefactoring.java:232)
	at org.netbeans.modules.refactoring.spi.impl.ParametersPanel$Prepare.run(ParametersPanel.java:1013)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1454)
	at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2036)
Comment 2 Ralph Ruijs 2012-11-23 23:01:34 UTC

*** This bug has been marked as a duplicate of bug 218766 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo