Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 218851 - Hide unsupported escape sequences in output
Hide unsupported escape sequences in output
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
7.3
All All
: P3 (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@platform
:
: 226023 226757 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-22 23:02 UTC by xgathos
Modified: 2013-03-13 02:10 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xgathos 2012-09-22 23:02:44 UTC
[ BUILD # : 201209220001 ]
[ JDK VERSION : 1.7.7 ]


The new feature of colored output doesnt strip the ansi escape codes from
output

as example:
[2KOK 
now shows a green background. but the [2K should be removed from output
Comment 1 Jaroslav Havlin 2012-09-24 08:02:53 UTC
Please, which application produces this output? Thanks.
Comment 2 xgathos 2012-09-24 09:39:01 UTC
PHPUnit 3.6.11
with colors="true" in configuration file
Comment 3 Jaroslav Havlin 2012-09-25 13:36:20 UTC
> PHPUnit 3.6.11
> with colors="true" in configuration file
Thank you.

The process outputs this character sequence:
"\u001B[30;42m\u001B[2KOK (1 test, 1 assertion)"

There are two control sequences:
 - "\u001B[30;42m"  - changes the color
 - "\u001B[2K"      - clears entire line (not supported)

The displayed ANSI escape codes are not related to background color, and IDE does not support them.

But we may at least hide them.
Renaming and changing to enhancement.
Comment 4 Jaroslav Havlin 2013-02-12 16:02:25 UTC
*** Bug 226023 has been marked as a duplicate of this bug. ***
Comment 5 Tomas Mysik 2013-02-13 09:05:26 UTC
Could we change it to defect and have it fixed for the next NB version please? We now use colored PHPUnit output by default so it would be nice if it could be fixed.

Thanks.
Comment 6 Tomas Mysik 2013-02-27 10:05:58 UTC
*** Bug 226757 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Havlin 2013-03-11 16:51:39 UTC
http://hg.netbeans.org/core-main/rev/8293ccf1d9c4
Fixed. Please verify. Thanks.
Comment 8 Quality Engineering 2013-03-13 02:10:48 UTC
Integrated into 'main-golden', will be available in build *201303122300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8293ccf1d9c4
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #218851: Hide unsupported escape sequences in output


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo