Bug 218601 - IndexOutOfBoundsException: Invalid line index=212 >= lineCount=212
IndexOutOfBoundsException: Invalid line index=212 >= lineCount=212
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Painting & Printing
7.3
All All
: P2 (vote)
: 7.3
Assigned To: Miloslav Metelka
issues@editor
EXCEPTIONS_REPORT
: 73_HR_FIX
: 219656 223907 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 10:23 UTC by Exceptions Reporter
Modified: 2013-02-06 11:25 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.68 KB, text/plain)
2012-09-19 10:23 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-09-19 10:23:42 UTC
Build: NetBeans IDE Dev (Build 201208200933)
VM: OpenJDK 64-Bit Server VM, 20.0-b12, OpenJDK Runtime Environment, 1.6.0_24-b24
OS: Linux

User Comments:
GUEST: typing stuff

larsomat: Pressing cmd+z (undo)




Stacktrace: 
java.lang.IndexOutOfBoundsException: Invalid line index=212 >= lineCount=212
   at org.netbeans.modules.editor.lib2.document.LineElementRoot.getElement(LineElementRoot.java:84)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.updateLineEndOffset(HighlightsViewFactory.java:301)
   at org.netbeans.modules.editor.lib2.view.HighlightsViewFactory.createView(HighlightsViewFactory.java:202)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createNextView(ViewBuilder.java:893)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createViews(ViewBuilder.java:730)
   at org.netbeans.modules.editor.lib2.view.ViewBuilder.createReplaceRepaintViews(ViewBuilder.java:684)
Comment 1 Exceptions Reporter 2012-09-19 10:23:44 UTC
Created attachment 124564 [details]
stacktrace
Comment 2 Milutin Kristofic 2013-01-08 15:50:01 UTC
*** Bug 223907 has been marked as a duplicate of this bug. ***
Comment 3 Milutin Kristofic 2013-01-08 15:50:07 UTC
*** Bug 219656 has been marked as a duplicate of this bug. ***
Comment 4 Marian Mirilovic 2013-01-21 09:40:10 UTC
103 reports ... at least P2
Comment 5 Marian Mirilovic 2013-01-22 17:50:16 UTC
P2 reported before cut-off ... treating as 7.3 HR FIX Candidate
Comment 6 Miloslav Metelka 2013-01-23 14:49:45 UTC
Cannot reproduce but it should be fixed.
http://hg.netbeans.org/jet-main/rev/d4e2880e9909
Comment 7 Quality Engineering 2013-01-24 03:02:19 UTC
Integrated into 'main-golden', will be available in build *201301240001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d4e2880e9909
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #218601 - IndexOutOfBoundsException: Invalid line index=212 >= lineCount=212.
Comment 8 Miloslav Metelka 2013-01-24 08:49:46 UTC
Integrated in release73:
d4e2880e9909 transplanted to 241d4396a86f
Comment 9 Quality Engineering 2013-01-24 12:28:11 UTC
Integrated into 'releases', will be available in build *201301240957* or newer. Wait for official and publicly available build.
Changeset: http://hg.netbeans.org/releases/rev/241d4396a86f
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #218601 - IndexOutOfBoundsException: Invalid line index=212 >= lineCount=212.
(transplanted from d4e2880e99090eb5cf32ba629b9d1508a0ab2cd5)
Comment 10 Milutin Kristofic 2013-01-24 16:51:06 UTC
I verified code
Comment 11 Jiri Prox 2013-02-06 11:25:46 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo