Bug 217426 - Cannot change font add effects to any options in the 'Highlighting" section of Fonts & Colors Options
Cannot change font add effects to any options in the 'Highlighting" section o...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Options
7.3
PC Windows 7
: P3 (vote)
: 7.4
Assigned To: Milutin Kristofic
issues@editor
: PLAN
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-26 17:15 UTC by bluebyliquid
Modified: 2013-04-18 02:20 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bluebyliquid 2012-08-26 17:15:54 UTC
The options to change the font and apply effects such as underline/strikethough/etc are not shown in the "Highlighting" section of the Font's & Colors section of the Options. To be more clear these Options show up for any choice in the "Syntax" tab but not the "Highlighting" tab.
Comment 1 Milutin Kristofic 2013-02-19 12:49:06 UTC
This is enhancement, since it was intended to not add font effects to highlighting options. 

It can be added font effects to highlighting, but can you describe a meaningful use-case?
Comment 2 bluebyliquid 2013-03-01 06:12:53 UTC
A large amount of reasons.

One it is common to highlight matching keywords and/or braces. Sometimes you want to underline the search values Sometimes you want to draw a box around them. It came up while trying to match editor window to match several other newer editors such as Sublime Text. I was unable to match many of these features which many of our end users find beneficial. 

Am I missing what purpose removing the effects was? It seems like it would have been more work to remove them.
Comment 3 bluebyliquid 2013-03-01 06:13:27 UTC
A large amount of reasons.

One it is common to highlight matching keywords and/or braces. Sometimes you want to underline the search values Sometimes you want to draw a box around them. It came up while trying to match editor window to match several other newer editors such as Sublime Text. I was unable to match many of these features which many of our end users find beneficial. 

Am I missing what purpose removing the effects was? It seems like it would have been more work to remove them.
Comment 4 Milutin Kristofic 2013-04-17 13:23:23 UTC
http://hg.netbeans.org/jet-main/rev/907a3edd5a4a
Comment 5 Quality Engineering 2013-04-18 02:20:47 UTC
Integrated into 'main-golden', will be available in build *201304172301* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/907a3edd5a4a
User: Milutin Kristofic <mkristofic@netbeans.org>
Log: #217426 - Cannot change font add effects to any options in the 'Highlighting" section of Fonts & Colors Options


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo