Bug 217329 - NoClassDefFoundError: org/openide/util/NetworkSettings
NoClassDefFoundError: org/openide/util/NetworkSettings
Status: RESOLVED DUPLICATE of bug 211962
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.1
All All
: P1 (vote)
: TBD
Assigned To: Ondrej Vrabec
issues@versioncontrol
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-23 21:06 UTC by Exceptions Reporter
Modified: 2012-08-30 15:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.42 KB, text/plain)
2012-08-23 21:06 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-08-23 21:06:01 UTC
This bug was originally marked as duplicate of bug 196563, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.1.2 (Build 201204101705)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.5-b03, Java(TM) SE Runtime Environment, 1.6.0_30-b12
OS: Windows 7

User Comments:
GUEST: During SVN usage I was not able to complete the commit/update due to this exception

GUEST: tried to commit changes in Project

GUEST: committing to SVN repository

GUEST: Error when trying to commit a project to SVN

GUEST: ??????




Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/NetworkSettings
   at org.netbeans.modules.subversion.config.SvnConfigFiles.setProxy(SvnConfigFiles.java:255)
   at org.netbeans.modules.subversion.config.SvnConfigFiles.storeSvnServersSettings(SvnConfigFiles.java:221)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.handle(SvnClientInvocationHandler.java:354)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invokeMethod(SvnClientInvocationHandler.java:321)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler$2.call(SvnClientInvocationHandler.java:166)
   at org.netbeans.modules.subversion.client.SvnClientInvocationHandler.invoke(SvnClientInvocationHandler.java:175)
Comment 1 Exceptions Reporter 2012-08-23 21:06:03 UTC
Created attachment 123485 [details]
stacktrace
Comment 2 Vince Kraemer 2012-08-27 16:45:33 UTC
this may need to get marked as a dup of issue 211962?
Comment 3 TomasKraus 2012-08-30 14:31:12 UTC
Well, we are not sure if this has something to do with JAX-WS.
Stack trace is identical to 196563.

Re-assigning to Bug3 196563 owner to evaluate this one.
Comment 4 Ondrej Vrabec 2012-08-30 15:08:48 UTC
- svn has correct dependency on openide.util
- all reports are from the IDE with glassfish support
- i checked most of the messages.log in the reports and there are dozens of java.lang.NoClassDefFoundError: org/openide/util/* messages with calls coming from other areas of the IDE. It's not a subversion problem this time.
- all reports are from versions < 7.2 (when 211962 was fixed)
This all makes me believe it is a duplicate of #211962

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo