Bug 216099 - The "Classical View" button does nothing
The "Classical View" button does nothing
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Quick Filechooser
7.2
All All
: P3 (vote)
: 7.3
Assigned To: Jesse Glick
issues@contrib
:
Depends on:
Blocks: 211215
  Show dependency treegraph
 
Reported: 2012-07-28 21:58 UTC by ent38
Modified: 2012-10-03 01:56 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot of the problem (45.00 KB, image/png)
2012-07-28 21:58 UTC, ent38
Details
Netbeans log (72.86 KB, application/octet-stream)
2012-07-28 22:01 UTC, ent38
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ent38 2012-07-28 21:58:43 UTC
Created attachment 122491 [details]
Screenshot of the problem

The "Classical View" button does nothing (when clicked, the button becomes grayed, but it doesn't restore the classical view).
Nothing relevant in NetBeans logs.

Product Version: NetBeans IDE 7.2 (Build 201207171143)
Java: 1.7.0_05; Java HotSpot(TM) Client VM 23.1-b03
System: Windows XP version 5.1 running on x86; Cp1252; fr_FR (nb)

Thx.
Comment 1 ent38 2012-07-28 22:01:18 UTC
Created attachment 122492 [details]
Netbeans log

Added NetBeans logs.
Comment 2 Jesse Glick 2012-07-30 13:43:33 UTC
Probably specific to XP L&F. I normally use Linux; sometime when I get a chance I will check behavior on XP.
Comment 3 dudy 2012-08-27 09:31:08 UTC
Got the same problem in Win7, but I tweaked my view to look like XP.


  Product Version         = NetBeans IDE 7.2 (Build 201207171143) (#b6c037585768)
  Operating System        = Windows 7 version 6.1 running on amd64
  Java; VM; Vendor        = 1.7.0_04; Java HotSpot(TM) 64-Bit Server VM 23.0-b21; Oracle Corporation

The IDE log says:

INFO [org.openide.explorer.view.TreeView]: Problems while painting
java.lang.NullPointerException
	at com.sun.java.swing.plaf.windows.XPStyle$Skin.getWidth(XPStyle.java:517)
	at com.sun.java.swing.plaf.windows.XPStyle$Skin.getWidth(XPStyle.java:521)
	at com.sun.java.swing.plaf.windows.WindowsTreeUI$ExpandedIcon.getIconWidth(WindowsTreeUI.java:158)
	at javax.swing.plaf.basic.BasicTreeUI.drawCentered(BasicTreeUI.java:1616)
	at javax.swing.plaf.basic.BasicTreeUI.paintExpandControl(BasicTreeUI.java:1506)
	at javax.swing.plaf.basic.BasicTreeUI.paint(BasicTreeUI.java:1219)
	at javax.swing.plaf.ComponentUI.update(ComponentUI.java:161)
	at javax.swing.JComponent.paintComponent(JComponent.java:778)
	at javax.swing.JComponent.paint(JComponent.java:1054)
	at org.openide.explorer.view.TreeView$ExplorerTree.access$1301(TreeView.java:1734)
[catch] at org.openide.explorer.view.TreeView$ExplorerTree.guardedPaint(TreeView.java:1876)
	at org.openide.explorer.view.TreeView$ExplorerTree.access$1600(TreeView.java:1734)
	at org.openide.explorer.view.TreeView$ExplorerTree$GuardedActions.run(TreeView.java:2198)
	at org.openide.util.Mutex.readAccess(Mutex.java:332)
	at org.openide.util.Mutex$1R.run(Mutex.java:1307)
	at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1921)
	at org.openide.util.Mutex.doWrapperAccess(Mutex.java:1328)
	at org.openide.util.Mutex.readAccess(Mutex.java:280)
	at org.openide.explorer.view.TreeView$ExplorerTree$GuardedActions.<init>(TreeView.java:2190)
	at org.openide.explorer.view.TreeView$ExplorerTree.paint(TreeView.java:1847)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JViewport.paint(JViewport.java:731)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at org.netbeans.swing.tabcontrol.TabbedContainer.paint(TabbedContainer.java:973)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at org.netbeans.core.windows.view.ui.MultiSplitPane.paint(MultiSplitPane.java:341)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JLayeredPane.paint(JLayeredPane.java:585)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at org.netbeans.core.windows.view.ui.MainWindow$1.paint(MainWindow.java:178)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paint(JComponent.java:1063)
	at javax.swing.JLayeredPane.paint(JLayeredPane.java:585)
	at javax.swing.JComponent.paintChildren(JComponent.java:887)
	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5228)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1482)
	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1413)
	at javax.swing.RepaintManager.paint(RepaintManager.java:1206)
	at javax.swing.JComponent.paint(JComponent.java:1040)
	at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:39)
	at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:78)
	at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:115)
	at java.awt.Container.paint(Container.java:1967)
	at java.awt.Window.paint(Window.java:3877)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:781)
	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:728)
	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:677)
	at javax.swing.RepaintManager.access$700(RepaintManager.java:59)
	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1621)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:701)
	at java.awt.EventQueue.access$000(EventQueue.java:102)
	at java.awt.EventQueue$3.run(EventQueue.java:662)
	at java.awt.EventQueue$3.run(EventQueue.java:660)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:671)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:158)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)
Comment 4 Jesse Glick 2012-09-04 16:58:01 UTC
(In reply to comment #3)
> java.lang.NullPointerException
>     at com.sun.java.swing.plaf.windows.XPStyle$Skin.getWidth(XPStyle.java:517)

This just looks like a JRE problem (report on bugs.sun.com, or file blocking issue here in platform/JDK Problems). Not sure if it is related to the reported problem.
Comment 5 Jesse Glick 2012-10-03 01:36:48 UTC
Reproduced on Linux. Only applies to file-type chooser dialogs; still works in dir-type dialogs.
Comment 6 Jesse Glick 2012-10-03 01:56:13 UTC
Somehow caused by ovrabec’s 2bb3c590df06, which seems to have made org.netbeans.swing.dirchooser.Module.isQuickFileChooser ineffective. Workaround seems to be to suppress dirchooser altogether: contrib #931239200723


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo