Bug 215189 - NoClassDefFoundError: org/openide/util/Enumerations$1RDupls
NoClassDefFoundError: org/openide/util/Enumerations$1RDupls
Status: RESOLVED DUPLICATE of bug 211962
Product: webservices
Classification: Unclassified
Component: JAX-WS
7.2
All All
: P2 (vote)
: 7.2
Assigned To: Denis Anisimov
issues@webservices
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 03:32 UTC by Exceptions Reporter
Modified: 2012-08-24 08:33 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.39 KB, text/plain)
2012-07-05 03:32 UTC, Exceptions Reporter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Exceptions Reporter 2012-07-05 03:32:39 UTC
This bug was originally marked as duplicate of bug 211962, that is already resolved. This bug is still valid, so this seems to be another bug, but it might be related.

Build: NetBeans IDE 7.2 RC1 (Build 201206272359)
VM: Java HotSpot(TM) 64-Bit Server VM, 20.8-b03-424, Java(TM) SE Runtime Environment, 1.6.0_33-b03-424-11M3720
OS: Mac OS X

User Comments:
GUEST: I have fedora 17 with LXDE, i had problem with deploying an webservice to glassfish instance. Netbeans printed on the console, the following stack trace:
/home/kburek/Projects/Webservice/korczynska-ws/nbproject/build-impl.xml:726: 
java.lang.NoClassDefFoundError: org/openide/xml/XMLUtil$1
	at org.openide.xml.XMLUtil.write(XMLUtil.java:406)
	at org.netbeans.spi.settings.DOMConvertor.write(DOMConvertor.java:146)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter$1.call(TargetModuleConverter.java:191)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter$1.call(TargetModuleConverter.java:183)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter.executeExclusively(TargetModuleConverter.java:351)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter.writeTargetModule(TargetModuleConverter.java:183)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModule.save(TargetModule.java:271)
	at org.netbeans.modules.j2ee.deployment.impl.pr

GUEST: I'm trying to right-click a folder in a project.

GUEST: Every time I use right click lauches the same error

GUEST: I'm trying to right-click the file in one of my project. It won't pop out.

GUEST: tried to right click on a folder in Files view

GUEST: Requested the details of the web.xml




Stacktrace: 
java.lang.NoClassDefFoundError: org/openide/util/Enumerations$1RDupls
   at org.openide.util.Enumerations.removeDuplicates(Enumerations.java:143)
   at org.openide.actions.FileSystemAction.createMenu(FileSystemAction.java:177)
   at org.openide.actions.FileSystemAction.createMenu(FileSystemAction.java:159)
   at org.openide.actions.FileSystemAction$Menu.<init>(FileSystemAction.java:269)
   at org.openide.actions.FileSystemAction$DelegateAction.getPopupPresenter(FileSystemAction.java:358)
   at org.openide.util.Utilities.actionsToPopup(Utilities.java:2764)
Comment 1 Exceptions Reporter 2012-07-05 03:32:43 UTC
Created attachment 121746 [details]
stacktrace
Comment 2 kitessakennedy 2012-07-25 14:13:48 UTC
I have the same problem.  I am trying to deploy a webservice to my development glassfish server and I get the same error.  See below.  Interestingly, it still deploys:
INFO: WS00019: EJB Endpoint deployed
 MEIS  listening at address at http://meis-devel:8080/MEISLabelsService/MEISLabels
INFO: WS00019: EJB Endpoint deployed
 MEIS  listening at address at http://meis-devel:8080/MEISSerializationService/MEISSerialization
INFO: WS00019: EJB Endpoint deployed
 MEIS  listening at address at http://meis-devel:8080/MEISBuildOrderService/MEISBuildOrder
INFO: WS00019: EJB Endpoint deployed
 MEIS  listening at address at http://meis-devel:8080/MEISManufacturingOrderService/MEISManufacturingOrder
INFO: WS00019: EJB Endpoint deployed
 MEIS  listening at address at http://meis-devel:8080/MEISStationUtilitiesService/MEISStationUtilities
INFO: MEIS was successfully deployed in 7,100 milliseconds.


However, this may be related to this issue:
Issue
210690
Summary
NoClassDefFoundError: org/openide/util/Enumerations$1RDupls


Possibly a problem with Glassfish.



java.lang.NoClassDefFoundError: org/openide/xml/XMLUtil$1
	at org.openide.xml.XMLUtil.write(XMLUtil.java:406)
	at org.netbeans.spi.settings.DOMConvertor.write(DOMConvertor.java:146)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter$1.call(TargetModuleConverter.java:191)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter$1.call(TargetModuleConverter.java:183)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter.executeExclusively(TargetModuleConverter.java:351)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModuleConverter.writeTargetModule(TargetModuleConverter.java:183)
	at org.netbeans.modules.j2ee.deployment.impl.TargetModule.save(TargetModule.java:271)
	at org.netbeans.modules.j2ee.deployment.impl.projects.DeploymentTarget.setTargetModules(DeploymentTarget.java:292)
	at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:207)
	at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:111)
	at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
	at sun.reflect.GeneratedMethodAccessor187.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
	at org.apache.tools.ant.Task.perform(Task.java:348)
	at org.apache.tools.ant.Target.execute(Target.java:392)
	at org.apache.tools.ant.Target.performTasks(Target.java:413)
	at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
	at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
	at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
	at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
	at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:283)
	at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:541)
	at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:153)
Caused by: java.lang.ClassNotFoundException: org.openide.xml.XMLUtil$1
	at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
	... 25 more
BUILD FAILED (total time: 21 seconds)
Comment 3 TomasKraus 2012-08-13 12:03:51 UTC
This looks like known problem related to Glassfish 3.1.2.
Please try to upgrade your GlassFish to 3.1.2.2 and let us know if you still see the same issue.
Comment 4 TomasKraus 2012-08-24 08:33:26 UTC
I'm closing this bug now. Feel free to reopen it if the same issue exists in 7.2 release with GlassFish 3.1.2.2.

*** This bug has been marked as a duplicate of bug 211962 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo